Rider won't start on Mac


I've installed Rider 2022.3.2 on my iMac Pro (several times now) but the software simply doesn't open. I don't even get the loading screen. Just nothing happens when I double click the icon. No matter if I try it from Applications, or via Unity project (2021.3.8f1) by "Open C# project" the result is always the same. 

The application is installed from DMG file. I don't have the license yet though it never offered me the possibility to get that. I updated to the latest version via Unity's package manager. I updated my OS and also tried this earlier version. I have never been able to open this software on my Mac.

I have a couple of .shader files in my project and also a single .cs file. 

Visual Studio and Visual Studio Code both open normally if I choose them instead of Rider.

1 comment
Comment actions Permalink

Problem solved.

The download link for Mac downloads the Apple Silicon version of the software. My computer uses Intel core. In Chrome you need to click the small arrow to choose from Intel and Silicon versions.


Please sign in to leave a comment.