"Developer certificate is not set up" Notification shows up each time I open a project.

I receive this notification each time I open a project:

ASP.NET Core developer certificate is not set up. This may cause errors on project start.

When I run set up certificates.

/usr/local/share/dotnet/dotnet dev-certs https --verbose --trust

With results of: 

Successfully trusted the existing HTTPS certificate.

How do I get Rider to honor the trusted certications?

I have tried delete and recreating certifications. Along with uninstalling and reinstalling Rider.


Hello Sreigle,

Thank you for reaching Rider Forum.

Could you please try adding the certificates in question to Preferences | Tools | Server Certificates page?

Please let me know of the result.



I resolved this by running the following command to export the certificate to a PFX file.

dotnet dev-certs https -ep ./certificate.pfx -p $CREDENTIAL_PLACEHOLDER$ --trust


Then import in "System Keychains" from "Keychain Access" (Mac)

After that Rider wouldn't popup notifications any more on my side. Hope this helps.


Thanks Bruce.

This worked for me.

It is also registering correctly on the Preferences | Tools | Server Certificates page.


Please sign in to leave a comment.