Some postfix completions not working

As mentioned in https://www.jetbrains.com/help/rider/2022.3/Postfix_Templates.html some postfix completions like .arg, .field, .cast etc does not show up as an option at all.

I have tried using the support system been I've been ignored for about a month now.
So here I am.
Here is examples of what I expect to happen:

static void Test(object obj)
{
    // Examples seperated by empty line; First line: my expression I expact the result to happen for, Second line: what (as far as I understand it) it is suppose to do
    
    // an example of a few that does NOT work:
    obj.cast
    ((SomeType)obj) // With SomeType being automatically selected for edit, then caret moved after the ending parencencies on enter or tab
    
    obj.arg
    SomeMethod(obj) // With SomeMethod being automatically selected for edit, then caret moved after the ending parencencies on enter or tab 
    
    obj.par
    (obj)
        
    obj.field
    // basically exactly what ctrl+r, f does pretty well. Same deal for .prop
    // Yes even if 'obj' is a more complex expression then just a local variable reference it still doesn't show up, like obj.ToString().field

    obj.to
    SomeAssignableExpression = obj;
    
    obj.sel
    // I'm not sure what this one is suppose to do, just to select 'obj' maybe?
    
    // an example of a few that does work but that I have some comments on:

    obj.ToString().var
    var s = obj.ToString(); // Even though this does work, 'obj.var' does not, seems unnessesary to hide that option
    
    obj.if
    if (obj) // With the caret left before the ')'. This doesn't work, but it does work if the expression results in a boolean value except it places the caret inside the block, which makes sense in the boolean only implementation it seems it has now.
             // I can understand the motivation behind that, but kinda semilare to the above one, some peolpe might prefer to write out the rest of the expression within the if statement after this step, then press tab or enter when they are done writing out the expression to move the caret to the block
    {
        
    }
}

Among the ones I mention does work above, another one that does work pretty reliably is .foreach

My last message to jetbrains before I got ignored was this video of me trying to use some of the broken postfix completions:
https://drive.google.com/file/d/1ocntmY18IcAqjG7HE1OSvRkKWgsB_HAD/view?usp=sharing

First action is me trying .to, then .arg, then showing .var works

 

If anyone has any ideas please do let me know.

0
2 comments

Hi Noah! 

Thank you for reporting this issue to YouTrack: RSRP-491741. As a possible workaround, these templates could be called manually by pressing `Ctrl+Space`. 

-1

Alexandra Guk  that's a work around if the dropdown lookup doesn't appear, in his video ( also happens for me) the dropdown does appear, its just it doesn't have a lot of the .net postfix templates it should have, it has a few of them, but a lot of them are missing....eg

 

0

Please sign in to leave a comment.