Rider: Which option disables hints on non-hovered text?


I can't find the option, but it must be there.

E.g. trying to code on one line, tooltip comes up for a future line, covering up what I'm trying to type. 

Pressing Esc as suggested gets rid of it for 1/2 second and then it's back. I'm really just after hints on whatever's being hovered over.



I suppose it could be an issue there. What Rider version do you use? Could you please try the latest Rider EAP and check if it works the same? 


On 2022.3.3 - RD-223.8836.53 (Windows).

Will EAP reindex?

As it can take quite a while with UnrealEngine's 3 million lines and isn't too convenient. But if you know it was something likely fixed in the 2 weeks since my release, I'll take the downtime in putting on the EAP.

Happy to turn off all popups in the meantime if there might be some option to do that.


Hello Stebboko,

Regarding the indexing - Rider indexes your game project and the engine the first time you open a project and will reindex them after every Rider update. When you open a project for the first time, it might take up to 10 minutes. It usually takes 5-15 minutes to index sources for the first time (per Rider version) and depends on hardware and indexing settings set in File | Settings | Languages & Frameworks | C++ | Unreal Engine). You may disable Indexing Unreal Engine source files to speed up the process.

Hope that helps.
Have a nice day!


I can't go down the EAP route unless you've got confidence you've addressed it. Too disruptive to take guesses, reinstall when EOL etc. My time is my money.

I have installed the stable release (RD-231.8109.212 (April 4)) that came out soon after I last posted.

Same behaviour is being exhibited and it's driving me insane.

As the original question asked, just tell me option to turn off these hints completely. The gif shows what they look like.

Hello Stebboko,

You can disable this hint by toggling the "File | Settings | Editor | General | Auto Import | Show 'Import missing references' popup in editor" option.

Hope that helps!

Excellent - I'll turn those off now. 


Hello Stebboko,

I am glad to hear that I was able to help you.
Should you have any other questions or difficulties, do not hesitate to contact support.

Have a nice day!

I'm afraid that didn't fix it - it's feeling more like a bug than than an option though. 

Anyway it's going to be a hard one to track down - so I'll just add blank lines between the line I'm working on and next line with the errors so the popup doesn't block what I'm typing.

In the meantime I'll see if I can determining more context as to what triggers it, as I don't think it happens all the time. But when it does happen, it's relentless. Rider restart doesn't fix either.




I'm afraid that didn't fix it

Could you please provide more information on what behavior did you exhibit when disabling the setting - 'Settings (`⌘ + ,` or `Ctrl + Alt + S`) >  Editor > General > Auto Import > Show 'Import missing references' popup in editor?
I reproduced the issue in Rider 2022.3.3, but when the mentioned setting is disabled, it doesn't occur anymore: https://i.imgur.com/wb6IYBz.gif
Also, try to invalidate caches - File > Invalidate Caches.. > enable Clear file system cache and Local History option > Invalidate and Restart.

it's feeling more like a bug than than an option though.

Yes, it is a bug and we will file it on our issue tracker promptly, and provide the link here for following the progress.


I created the mentioned issue in YouTrack: https://youtrack.jetbrains.com/issue/IDEA-320393
You can vote and follow it for progress updates.


Please sign in to leave a comment.