Two possible bugs in Run/Debug Configuration


I have found 2 possible bugs in Rider. I didnt find much information online, so I hope I will get some help here.

1.Bug - Shell script in before launch options doesnt work on windows

In Run/Debug Configuration when I create a Shell Script like this: - Simple command Echo Done. I Try to Run this configuration and it works - But, if I add this configuration as Before launch options  I get error: 

/bin/sh is linux path, but I am on windows, and if I run the script on its own it works. I tried to reproduce this problem on linux - it works without a problem.

2.Bug - External tool SSH - cant find path. 

In Run/Debug Configuration in Before launch options a create External remote tool like this:

Connection to ssh works, so with the help of a Rider, a picked the file and working directory, arguments are empty since, this is just a test.

When a run the external tool a get error:

(The file or directory name or volume label is incorrect.)

I try to change the path a lot - chaning slashes \ /, removing the first slash, but non of that works.


Thank you in advance

JetBrains Rider 2023.1
Build #RD-231.8109.212, built on April 4, 2023
Licensed to Jaroslav Súkeník
Subscription is active until December 16, 2023.
Runtime version: 17.0.6+10-b829.5 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 11.0
.NET 7.0.2 (Server GC)
GC: G1 Young Generation, G1 Old Generation
Memory: 1500M
Cores: 8

Non-Bundled Plugins:
    GLSL (1.24)
    com.intellij.javafx (1.0.4)
    Batch Scripts Support (1.0.13)
    avalonia-rider (1.0.3)
    com.intellij.ideolog (
    Key Promoter X (2023.1.0)
    Abc.MoqComplete.Rider (2022.3.0.2)
    AceJump (3.8.11)
    com.samdark.intellij-visual-studio-code-dark-plus (2.6)


Would you mind taking a look at Tools -> Terminal to check configuration of shell path ? Mine looks like this (but I am on Linux, so that's ok):


Shell path is powershell.exe


Hello Jaroslav,

Thank you for reaching Rider Forum.

As for the first bug, I was able to find it already in our system. It has ID: IDEA-277486. Please upvote the issue for a greater awareness. 

As for the second bug, I could not reproduce it on my test environment. Could you please reproduce the issue and share the logs fro Help > Collect Logs? Upload them to our shared storage at and provide me with the ID of the upload. 

Thank you in advace!


Please sign in to leave a comment.