unable to find Unity libraries

Answered

I just have installed the latest Rider EAP

Installed Unity plugin from the main page

Linked to mono from Unity 5.5.1 at /Applications/Unity/Unity.app/Contents/MonoBleedingEdge

However  using UnityEngine; is highlighted red.

Am I miss something?

2 comments
Comment actions Permalink

Have you created the project from within Unity, or via New Project in Rider? When you create it from a Unity project, it will create the .csproj file with the correct references to the Unity libs. You might want to also install the Untiy3dRider plugin into Unity to allow for automatically opening the C# project file in Rider, rather than Unity's version of MonoDevelop.

1
Comment actions Permalink

Great! Thanks!

0

Please sign in to leave a comment.