Rider - Run ASP .NET on Browser


hi, when i use visual studio on mac or xamarin for a ASP . NET project i make click in run an d my web app run in the browser. how can i make that on Rider? thanks!


+1 How do we do this?


For now browser doesn't automatically start.

You can click the link (as shown at the attached screenshot) or open iisexpress in the windows tray and there is also possibility to open website.


@Ivan, using this method, any breakpoints that I set in my code are not hit. I'm using Rider 2017.1.1 on macOS Sierra (10.12.6). I created a brand new ASP.NET Core Web API project. I haven't changed anything from the skeleton template, and I'm not sure what kind of configurations are needed to allow stepping through the code.


For default ASP.NET Core Web API project you would need:
1. Start the Debug
2. Put brakepoint inside 

public IEnumerable<string> Get()
return new string[] { "value1", "value2" };

3. Open http://localhost:5000/api/values in browser


@Ivan, I've tried that, but it appears that the Debugger thinks my project is a console application. When I click the Debug button, it opens the Debugger console with the following command:

"/Applications/Rider 2017.1.app/Contents/lib/ReSharperHost/runtime.sh" "/Applications/Rider 2017.1.app/Contents/lib/ReSharperHost/JetBrains.Debugger.Worker.exe" 62160 /usr/local/share/dotnet/shared/Microsoft.NETCore.App/2.0.0

And then the debugger stops. It never starts listening on port 5000. So when I go to http://localhost:5000/api/values in the browser, I get "This site can't be reached." If I Run the project instead of Debug, then it starts listening on 5000 and I get the string values output, but my breakpoint does not get triggered (because I'm not in debug mode).

So I guess I don't know how to get the debugger to realize that it's a web project and to make it listen on 5000.


@Travis What are your dotnet core version and Rider version? 2017.1.1+dotnetcore 2 doesn't work fine. 
Consider upgrading to 2017.2EAP.


I updated to 2017.2 EAP and it is now working. Thanks!


Please sign in to leave a comment.