Cannot load the project with the current MSBuild toolset. Please ensure MSBuild 15.0 is installed.


Hey there,

I am running Ubuntu 17.04, however whenever I try to create a project it gives me the following message:

22:49 Project 'ConsoleApplication1' load failed
Cannot load the project with the current MSBuild toolset. Please ensure MSBuild 15.0 is installed.
Install the latest Mono from

I ensured that the latest versions of mono-complete and .NET Core SDK are installed on my system. Creating a mono project seems to work fine by the way. How do I fix this problem?

Thanks in advance.


apt-get install msbuild
should help.


Awesome! Thank you so much. That fixed it.


Sorry to disturb again, but on my desktop it says

"Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package msbuild"

Any idea on what I'm missing there? On my laptop it worked fine for some reason.

When I try to run from MSBUILD I get the following error:

sudo ./
Installing dotnet cli...
Restoring BuildTools version 1.0.27-prerelease-00927-05...
Failed to initialize CoreCLR, HRESULT: 0x80131500


>apt-cache policy msbuild
  Installed: 15.1+xamarinxplat.2017.
  Candidate: 15.1+xamarinxplat.2017.
  Version table:
 *** 15.1+xamarinxplat.2017. 500
        500 wheezy/main amd64 Packages
        500 wheezy/main i386 Packages
        100 /var/lib/dpkg/status

Probably you don't have those sources listed in /etc/apt/sources.list.d?


The last resort is to compile msbuild and select it in Rider Settings -> Toolset and Build -> Use MsBuild version: "Custom".



MsBuild.dll is part of standard SDK installed using common way. But exception occurs when trying to use it.

Why Rider does not simply use dotnet build in case of .Net Core app ?


For now Rider can't use dotnetcore msbuild and relies on mono msbuild.

We are struggling to support dotnetcore msbuild directly. Technically it requires rewriting part of our core from full dotnet to dotnetcore.
Please follow this request


Is there any workaround on Windows?  I don't have VS 2017, which seems to be necessary to build the MSBuild version Rider requires.


This seems to happen on Windows even with latest version of VS 2017 installed (Version 15.1 - 26403.7)?

What gives? How to fix this?


Please sign in to leave a comment.