Rider is not building several solutions in same time.


Steps to reproduce:

1. Open one solution. Build it. It built with success.

2. Open second solution using new Rider instance (the first one is still opened). Build it. No success.

Tried to disable Resharper build. Tried to switch between different MSBuilds. Both with no luck.


When building by msbuild build log: 

File logger: "C:\Users\sbr\.Rider10\system\log\BuildLogs\msbuild-output.log"
C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\15.0\Bin\MSBuild.exe "/property:Configuration=Debug" "/property:Platform=Any CPU" "/property:SDKToolingDirectory=C:\Program Files\dotnet" "/t:Build" "/logger:C:\Program Files\JetBrains\Rider 171.4089.466\lib\ReSharperHost\JetBrains.ReSharper.MsBuildEventLogger.dll;52012" /m /fileLogger1 "/fileloggerparameters1:LogFile=C:\Users\xxx\.Rider10\system\log\BuildLogs\msbuild-output.log;" "C:\XXXXXX.sln"
Build succeeded at 13:29:41


When building using Resharper build:

Build started at 13:45:54
0: ------- Project started: Project01
1: ------- Project started: Project02
2: ------- Project started: Project03
0: ------- Project finished: Project01. Succeded: False. Errors: 0. Warnings: 0
1: ------- Project finished: Project02. Succeded: False. Errors: 0. Warnings: 0
2: ------- Project finished: Project03. Succeded: False. Errors: 0. Warnings: 0
Build completed in 00:00:01.029
Build succeeded at 13:45:55


It's so annoying and very strange that no one posted this yet (and yes, I saw https://rider-support.jetbrains.com/hc/en-us/community/posts/115000153304-Rider-EAP-some-projects-not-building?input_string=The%20second%20(third%20and%20etc)%20solution%20is%20not%20building)


It happened several EAPs ago. And I was hopping it will be fixed.

I hope you have bright ideas.

1 comment

We have addressed several build problems related to multisolution, so expect a fix in next EAP build.


Please sign in to leave a comment.