IDE seems to be using an old compiler, not sure why?

Completed

I seem to be having an issue with the IDE whereby it has compiler errors suggesting an older language version, but I set everything up to be the latest I could find. This is an example of the errors I have:

In my csproj file I have:

<TargetFrameworkVersion>v4.6.1</TargetFrameworkVersion>

And I have a Calpurnius.csproj.DotSettings with CSharpLanguageProject/LanguageLevel/@EntryValue">CSharp60</s:String>

My System dll is: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.6.1\System.dll

 

Does anyone know why it might think I'm still on an old language version and give those errors?

 

 

2 comments
Comment actions Permalink

Check the Toolset in Rider settings and LangVersion in csproj.

0
Comment actions Permalink

Thanks for the tip, I installed the latest msbuild from here https://docs.microsoft.com/en-us/visualstudio/msbuild/what-s-new-in-msbuild-15-0 and then changed the Toolset settings to point to the dll it installed and that worked.

0

Please sign in to leave a comment.