Rider RC cannot find NETFramework,Version=v4.5.2 on mac

Completed

Since upgrading from the most recent EAP to the RC, the solution I am working with no longer builds. I now see errors like this for all projects:

The reference assemblies for framework ".NETFramework,Version=v4.5.2" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend. at (1111:5)

This solution targets multiple frameworks - netstandard and fullframework. 

Has something changed with how Rider now handles this?

Example csproj:

<?xml version="1.0" encoding="utf-8"?><Project Sdk="Microsoft.NET.Sdk" ToolsVersion="15.0">
<PropertyGroup>
<TargetFrameworks>netstandard1.5;net452</TargetFrameworks>
<Version>0.1.6-dev</Version>
</PropertyGroup>
<PropertyGroup Condition="'$(TargetFramework)' == 'net452'">
<TargetFrameworkVersion>v4.5.2</TargetFrameworkVersion>
</PropertyGroup>
<PropertyGroup>
<OutputType>library</OutputType>
<Authors>Proto.Actor Team</Authors>
<Description>Ultra-fast distributed actors for .NET.</Description>
<PackageLicenseUrl>http://www.apache.org/licenses/LICENSE-2.0</PackageLicenseUrl>
<PackageProjectUrl>http://proto.actor/</PackageProjectUrl>
<PackageIconUrl>http://proto.actor/images/logo.png</PackageIconUrl>
<RepositoryUrl>https://github.com/AsynkronIT/protoactor-dotnet</RepositoryUrl>
<PackageTags>actors actor model concurrency proto protoactor</PackageTags>
</PropertyGroup>
</Project>
2 comments
Comment actions Permalink

Try to switch the used msbuild in the Rider settings.

0
Comment actions Permalink

Thanks! looks like it worked.

0

Please sign in to leave a comment.