Not able to connect to TFS




i am trying to get the TFS started in Rider, but it seems like, that i can not connect to the TFS.  I get the error, that the authentication failed. But I am 100% sure that i entered the correct credentials and also tried it on visual studio to be sure. Does anybody else has this issue?


Our URL is: https://tfs.intern:443/  and we do not add a /tfs at the end. Is there something i am doing wrong?


This is what we got from the admins ;)



Edit: What i also tried is the TFS Integration Plugin, wich enabled me to log in (same URL) and checkout a project. But the VCS does not recognize the files as under version control and edits are not being recognized. If I add all files, changes are recognized, wich is weird, as i thought they were not added to vcs... 


this is the commit dialog after adding eveything and edit one file


and this is the "changes" after a fresh checkout. The 4 i Default are the rider xml files 


Does anybody else experience this?

1 comment

Ok, i narrowed it down a bit:

It looks like you can not use the same workspace as VS, at least my Rider never recognizes changes when i use the same WS as VS. 

When i use Rider in its own workspace it takes 4-5 hours to scan a project for changes, after that it  "works". "Working" means Rider recognizes changes and i could commit. Sadly the plugin frequently crashes, and just closes the VCS Window for no apparent reason and after that i can not open it again. So for a checkin i usually have to restart Rider. 

But the next Problem is, that i can not check in without an attached Task and commit note (Company Policy). And the VCS Integration of Rider somehow does not treat the comment as a check in note, like VS does and I have not figured out how to attach a Task. The TFS Querys also do not work in Rider, so i would have to search for my tasks by hand.


It is just a puzzle to me why this TFS Integration is so hard. I mean this is something really fundamental...


Please sign in to leave a comment.