Application Exception: IsDebuggerPresent

Completed

System.EntryPointNotFoundException

IsDebuggerPresent

Description: HTTP 500.Error processing request.

Details: Non-web exception.

Exception stack trace:
at (wrapper managed-to-native) Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CompilationSettingsHelper:IsDebuggerPresent () at Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CompilationSettingsHelper.get_IsDebuggerAttached () [0x00000] in <849423e7971d4811a04a278979785bfe>:0 at Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CompilationSettingsHelper..cctor () [0x00019] in <849423e7971d4811a04a278979785bfe>:0
3 comments
Comment actions Permalink

Any luck figuring out this exception? I am running into the same thing.

1
Comment actions Permalink

Ok, so after many days of staring at this error (and only getting this page when I searched for it) I finally found a solution. If you haven't found a solution yet check the answer to this: https://stackoverflow.com/questions/35351134/mod-mono-asp-mvc4-error-system-security-securityexception-couldnt-impersonat. Commenting out the CodeDom stuff worked like a charm for me, it seems like it's overwriting Mono's own compiler which I know I was not trying to do. Hope this helps someone out there!

2
Comment actions Permalink

I started Rider on Ubuntu 18.04.3 LTS, created a vanilla ASP.NET web application and started. Was pretty stumped that it didn't work right away. Thanks to you, this issue resolved quickly! Anybody got the same problem? What's your OS?

0

Please sign in to leave a comment.