Slow debugger while runnig Nunit test

Completed

Thank you guys for awesome IDE, nice to see how fast it is getting better and better.

We have notices that running nunit tests in debug using Rider is significantly slower than in VS's 

Here is piece of debugger worker log with huge timing gap: 

 

16:04:33.757 |I| DebuggerWorker                | Calling instance method System.Collections.Generic.HashSet`1<System.String>::get_Count() with actual parameters System.Collections.Generic.HashSet`1[System.String]

16:04:33.757 |I| DebuggerWorker                | Starting invoke for instance method System.Collections.Generic.HashSet`1<System.String>::get_Count()

16:04:33.757 |I| DebuggerWorker                | Eval Finished — OnEvalComplete

16:04:33.757 |I| DebuggerWorker                | Invoke instance method System.Collections.Generic.HashSet`1<System.String>::get_Count() succeeded in 5000 ms

16:04:33.757 |I| DebuggerWorker                | RuntimeInvokeCompleted.

16:04:33.757 |I| DebuggerWorker                | Calling instance method System.Collections.Generic.HashSet`1<System.String>::get_Count() with actual parameters System.Collections.Generic.HashSet`1[System.String]

16:04:33.757 |I| DebuggerWorker                | Starting invoke for instance method System.Collections.Generic.HashSet`1<System.String>::get_Count()

16:04:33.757 |I| DebuggerWorker                | Eval Finished — OnEvalComplete

16:04:33.757 |I| DebuggerWorker                | Invoke instance method System.Collections.Generic.HashSet`1<System.String>::get_Count() succeeded in 5000 ms

16:04:33.757 |I| DebuggerWorker                | RuntimeInvokeCompleted.

16:04:33.757 |T| SEND                          | endpoint `DebuggerWorkerModel.activeSession.$.executionContext.$.computeValueChildren`::(DynamicServer/2), response = JetBrains.Platform.RdFramework.Tasks.RdTaskResult`1[JetBrains.Rider.Model.DebuggerWorker.ComputeValueChildrenResult]

16:06:12.957 |T| FrontendDispatcher            | Queuing task

16:06:12.957 |T| FrontendDispatcher            | Awakened

16:06:12.957 |T| FrontendDispatcher            | Process incoming task

16:06:12.957 |T| RECEIVED                      | endpoint `DebuggerWorkerModel.activeSession.$.executionContext.$.evaluateExpressions`::(DynamicServer/6), request = EvaluateArg (

  frameId = 23

  expressions = [

    "<removed>"

  ]

)

 

It is not in suspension on brakepoint and this is biggest gap I have noticed, majority are significantly slower.  Not sure if it helpful but this is only we have 

Can you please have a look maybe advice any configuration change to improve debugger performance ? 

Thanks

 

2 comments
Comment actions Permalink

Issue mentioned above is not relevant anymore using new Rider v2017.2.1 

Here are some results running test to hit  target breakpoint in debug 

Visual Studio    2m:10s

Rider v2017.2.1    2m:30s

Rider v2017.2    12m:00s

Thanks JB for such a long hoped-for fix !

0
Comment actions Permalink

We apologise to not giving feedback in a proper time. 

This issue related to an old version and now should be resolved. 

Please, contact us if you still have this issue or in case of any other questions or problems. 

Thank you! 

0

Please sign in to leave a comment.