[Xamarin]Error running Android Default: Failed to parse Activity Name


When trying to debug a Xamarin Forms app in Android Emulator, I always receive this message. The app is being deployed in emulator but not start to debug.


"Error running Android Default: Failed to parse Activity Name"


PS: Same solution build and debug without problems at Visual Studio


I have the same message and can not debug Xamarin Forms apps on device under Rider, but it has been build and deployed successful.

Visual Studio works good.



Is it on Rider 2017.1.1 or Rider 2017.2 EAP?


This problem reproduces on both versions 2017.1.1 and 2017.1.2 (September 15). I just tried update Rider.


Steps to reproduce:

1) Create default Xamarin.Forms solution at Visual Studio 2017 (in my case PCL based template)

2) Try to build and debug Android app via VS. It is ok.

3) Try to build and debug Android app via Rider. Fail occurs on debug step: "Error running Android Default: Failed to parse Activity Name"


Any information about a fix?


I have tried to reproduce it, but everything works as expected.
What api_level in Android SDK is used in your environment? I used 23.



In my case this bug reproduced even when I create default Android project via Rider. Maybe it is important what kind of device you use, I use Philips S308 Android 4.2.2.


10:57 AM Platform and Plugin Updates: Rider is ready to update.

11:07 AM Build succeeded at 11:07:22

11:08 AM Error running Android Default: Failed to parse Activity Name


I tried update Rider to 2017.2 EAP but I get another errors (used default installation).

11:35 AM Project 'AndroidApp2' load failed: The imported project "C:\Program Files (x86)\Microsoft Visual Studio\Preview\Community\MSBuild\Xamarin\Android\Xamarin.Android.CSharp.targets" was not found. Also, tried to find "Xamarin\Android\Xamarin.Android.CSharp.targets" in the fallback search path(s) for $(MSBuildExtensionsPath) - "C:\Program Files (x86)\MSBuild" . These search paths are defined in "C:\Program Files (x86)\Microsoft Visual Studio\Preview\Community\MSBuild\15.0\Bin\MSBuild.exe.Config". Confirm that the path in the <Import> declaration is correct, and that the file exists on disk in one of the search paths. C:\Users\Makeman\RiderProjects\AndroidApp2\AndroidApp2\AndroidApp2.csproj at (78:11)

11:35 AM MSBuild targets were not found: Make sure that all SDKs required for projects in this solution are installed, or specify a different MSBuild version in settings.

11:35 AM Xamarin.Android SDK was not found: Rider was unable to find Xamarin SDK on this machine. Xamarin-based projects will not be loaded. Please install Xamarin SDK or change toolset.


Riders 2017.1.2 and 2017.2EAP at the same time and solution.


Please check that MSBuild 15.0 inside Microsoft Visual Studio directory is used (File | Settings | Build, Execution, Deployment | Toolset and Build)


Thanks, Julia! This solves problem with load and build. But there is small UI bug with path trim (see screenshot, please).


12:04 PM Error running 'Android Default': Failed to parse Activity Name

reproduced on Rider 2017.2 EAP


Could you please create an issue on Youtrack or a Support ticket and attach zipped log folder there (Help -> Show logs in explorer)? 


This bug is fixed in the next EAP, see https://youtrack.jetbrains.com/issue/RIDER-7986. I mean that you should report a bug for "Failed to parse Activity Name", sorry for the confusion.


Check :)



Is there bug of EAP 2017.2 that with default installation selected incorrect version of MS Build? Release 2017.1.2 looks good.


Thanks! We also need log files to start investigating the issue :)


Log attached :) What about default MS Build path with installation?


We will investigate the issue with MS Build path as well. Please see my comment on Youtrack - we need more logs to study.


Full log folder attached.


Hello everyone I have big problem with Rider with Xamarin Android

What is shit?? Why do I should configure hard. If I am new for creating Android with C# Please could you stop to scam us! Because I am new for Rider under Ubuntu. I think they don't care to Linux users. PLEASE DO NOT IGNORE TO LINUX USERS!

I want know how do I compile with Android from Rider. I am very disappointed - I think I don't buy Rider yet because Rider makes shit. I have already tried I know I have e-mail but they don't help me. I have redden Xamarin.Android and Rider since Rider 2017.x But I am using Rider 2018.3 on Ubuntu 18.04

Thanks for replying if I get answer


PS: Also Xamarin.Forms has many error. What does it always get bad? My god. I thought Czech Republic creates great tools like Rider or IntelJ etc...


Hey there. I just had the same error with Rider 2020.2.

However, it was my bad due to the removal of the following lines in the MyApp.Android.csproj:

<Compile Include="MainActivity.cs" />
<Compile Include="SplashActivity.cs" />
<Compile Include="Resources\Resource.designer.cs" />

Yeah, this should not be removed :-)
I hope this helps someone


Please sign in to leave a comment.