How to prevent .lua files from being auto excluded by Rider?

Completed

I'm trying to prevent Rider exclude Lua files auto automatically.

Part of our Unity project is written in Lua. 

Unfortunately, it seems like Rider will exclude files using .lua as file extension.

I have double checked "File Types => Ignore files and folders", and I'm sure I never add .lua in there.

If I use other extension, then everything is fine, I can see these files in the project window.

How do I prevent .lua files from being excluded? 

2 comments
Comment actions Permalink

Well, after some searching, I found when I create a .lua file, {ProjectName}.csproj won't add a new record like "<Compile Include="Properties\test.lua" />".

And it seems like Rider needs "Compile Include" records, otherwise, files won't show in the project window.

I wonder it's there any configuration that I can prevent this annoying problem, I don't want to use other IDE like Visual Studio Code just because they can show .lua files. 

0
Comment actions Permalink

Well, I just solve this "problem" by consulting with others.

To show Lua files, we need to change Unity Editor Settings.

Open Unity Editor Settings => C# Project Generation => Additional extensions to => add "lua" in the field

=> Switch back to Rider and wait for sync

 

0

Please sign in to leave a comment.