Using up/down-arrows when switcher is active does not work on MacOS


I am currently evaluating the Rider IDE. When I am switching between the open documents I always use CTRL-Tab followed by CTRL-arrow regardless of the IDE I am using. I was happy when I saw that Rider should support this but no luck with up/down-arrows. The left/right-arrows works fine for me. Is some configuring needed to make this work or should it work out of the box? I have already checked the MacOS key configuration and nothing there is conflicting with this.

Anyone with information regarding this?



I'm using version 2020.2.4 on Windows, and it still doesn't work. :(


Hello Quxn6, have just checked it and it seems to work well, just as it is described in the corresponding Help section. Could you please specify what exactly not working, what happens when you try to switch between open files via switcher and up/down arrow keys? Could you please also check the shortcut in File | Settings | Keymap?


Olga Diakonova, I'm not the original poster, but I'm seeing similar behavior on linux. I'll use the screenshots and filenames from the Help.

Pressing Ctrl + Tab brings up the switcher. Everything below assumes you're still holding down the Ctrl key.

What works - Pressing Tab highlights ProjectModelTaskHandler.cs (in the help example). Pressing Shift + Tab highlights CSharpReferenceProvider.cs. Pressing Left Arrow highlights 2: Favorites. Pressing Right Arrow highlights CallTreeService.cs.

What doesn't work - Pressing Arrow Down does not highlight ProjectModelTaskHandler.cs (in the help example). Arrow Up does not highlight CSharpReferenceProvider.cs.

Pressing the Arrow Up/Down works in other editors (Data Grip for example), but not in Rider.


Hi Tate

Does it work for you inside the 'Recent Files' dialog (Ctrl+E): with and w/out Ctrl pressed?

Does it help if you temporarily disable all downloaded plugins under File | Settings | Plugins > Installed and restart the IDE via the File | Invalidate Caches & Restart menu option.


Hi Arina Efremova,

The up/down arrows work in the 'Recent Files' dialog only when Ctrl is not pressed. The up/down arrows stop working when I hold Ctrl.

I tried disabling downloaded plugins (Heap Allocations Viewer and Ideolog) and doing the Invalidate Caches & Restart, but that did not change the behavior.



The shortcuts may be intercepted by your OS or some other software. Do you have any keyboard management programs installed? Check this website for a list of possible perps.


Arina Efremova

After some experimenting, it appears to be a conflict with custom shortcuts for Ctrl + Up / Ctrl + Down. I had assigned those keys to 'Navigate in File' > 'Next Method' / 'Previous Method'. Removing those custom assignments resolves the issue.

Could be considered a bug, but now that I know the cause, I can choose the most convenient setup (with or without the keymaps).

Thanks for the assistance.


Please sign in to leave a comment.