Rider project cannot be loaded on macOS. Method Open of ProjectRootElement cannot be found.

Hello,

I have installed the latest RIder version on my MacBook Pro (running macOS High Sierra 10.13.2) and when I try to add a project to a solution, upon loading the project the IDE stalls with the following error: "Project '<PROJECT_NAME>' load failed: Method 'Microsoft.Build.Construction.ProjectRootElement.Open' not found." Then the project does not load at all.

The project was supposed to be a very basic console application. Is there some setting that needs to be done on macOS that I am missing?

 

Thanks for suggestions.

4 comments

Hello,

Probably, this is caused by a wrong path to MSBuild. What is selected in "Use MSBuild version" field it in "Rider | Preferences | Build, Execution, Deployment | Toolset and Build"?

 

0

Hello,

the one selected is Auto detected (15.0). Here's a screenshot of the contents of the drop down.

I believe this should be correct.

Thanks for the response anyway, Julia.

0

Ondrej Simon, Selecting MSBuild 14.0 might help. There is a known issue in Rider 2017.3 with Mono MSBuild v15.0, see RIDER-12609.

Alternatively, you could download the latest Nightly build via JetBrains Toolbox app, the bug is already fixed there.

1

Hey Julia,

I am sharing a bit more information with you. This is the version I am currently running:

JetBrains Rider 2017.3
Build #RD-173.3994.1125, built on December 26, 2017
JRE: 1.8.0_152-release-1024-b10 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.2

As of the moment, I've got a single .NET Core CLI, the executable path is at /usr/local/share/dotnet/dotnet.

Currently I've got 3 version of Mono framework installed, 2.10.9, 4.8.0 and 5.4.1.

The MSBuild versions are the following:

Follow the actual interactions:

Chosen Mono executable path: 2.10.9

MSBuild versions:

  1. 15.0 - project does not load,
  2. Auto detected (15.0) - project does not load,
  3. Latest installed (15.0) - project does not load.

Other options are not available. All options fail with the following error:

14:41 Project 'hello-world' load finished with warnings: The reference assemblies for framework ".NETFramework,Version=v4.6.1" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend. at (1124:5)

Chosen Mono executable path: 4.8.0

MSBuild versions:

  1. 12.0 - project loads,
  2. 14.0 - project loads,
  3. 15.0 (/usr/local/share/dotnet/sdk/2.1.3/MSBuild.dll) - project does not load, fails with the same message as when using Mono 2.10.9,
  4. 15.0 (/Library/Frameworks/Mono.framework/Versions/4.8.0/lib/mono/msbuild/15.0/bin/MSBuild.dll) - project does not load, Open method not found,
  5. Auto detected (15.0) - project does not load, same error as 4),
  6. Latest installed (15.0) - project does not load, same error as 4).

Chosen Mono executable path: 5.4.1

Project fails to load only when choosing 15.0 (/usr/local/share/dotnet/sdk/2.1.3/MSBuild.dll), with the same error as when using Mono 2.10.9. Otherwise it works.

Thanks for the input.

Ondrej

0

Please sign in to leave a comment.