Debugging is slow.

Hi guys,

I'm using Rider(2023.1.2) for game development with Unreal Engine(5.1.1).

Both Step over(F10) and Step into(F11) take really long time to respond. How do I identify the cause of it?

3
9 comments

I'm experiencing the exact same issue.
Hopefully Jetbrains will fix the issue soon.

0

Hello Coquid93,

Are you experiencing this issue with the latest Rider version (2023.3.3)? If you are using the latest version of Rider, could you specify your OS and the UE version you are using?

1

I'm also experiencing this (in 2023.3.3). There's a noticeable delay (sometimes up to 10 seconds) before the watch window (or the variable state shown in the source code window) updates.

If I ever need to do any serious debugging, I *have* to switch back to Visual Studio - which is unfortunate.

0

Hello Neil Griffiths,

Would it be possible to send us debugger trace logs that would help us investigate this behavior?

  • Use Help → Diagnostic Tools → Choose Trace Scenarios action and pick Debugger trace scenario
  • Reproduce the problem
  • Use Help → Collect Logs to generate the log archive
  • Disable the Debugger trace scenario

You can use the Upload Service to send us the logs (logs are not publicly accessible) and leave a comment with Upload ID in this thread.

0

Kirill Filin

Here's the version of Rider I'm currently using
JetBrains Rider 2023.3.3
Build #RD-233.14015.60, built on January 19, 2024

And i am using the current source version of the Unreal Engine code, forked from the 5.3.2 Release version.

I have reproduced the issue and uploaded it. (2024_02_05_229bohBX8dtJfCnFWDPD5L)

When I actually turned on Diagnostics and tried to reproduce the problem situation, Step into is faster than I thought, but I couldn't check the variable value for a very long time with “Collecting...” message.
It felt like I wasn't actually stepping.

I would be grateful if you could check it out.

Oh, and there's another problem,

the user-friendly view of Unreal data types is not being applied.

I opened urpoject as a Rider, and noticed that the Engine Solution View shows UEDataFormatters_2ByteChars.py.
I've tried using the paths "UEDataFormatters" and "UEDataFormatters_2ByteChars" in the "script import" line of the ~/.lldbinit file, but the user-friendly view is not being applied.

I hope you can check this as well.

0

Is there any update on this topic? This issue recently started affecting multiple people on the team, disrupting their work.

0

Hello everyone,

We are still investigating the issue, however we've recently discovered that a couple of third-party antivirus/data protection solutions are affecting debugger on Windows and Mac systems. 

Here's the list of products that can cause debugging performance issues:

  • CrowdStrike Falcon
  • Hitman.Pro Alert

Please let us know if you are using one of these solutions in your environments.

0

No, I'm using neither of those. I'm able to easily reproduce this issue with *any* UE5 project on both my work PCs and my home PCs. All I have to do is add some variables in the Watch window, insert a breakpoint in, say, any actor's Tick() function and let it hit the breakpoint a couple of times. Both the Watch window and the variables take a significant amount of time to be able to see their current values.

Since I can reproduce it on multiple PCs (that are also a mixture of Windows 10 and 11), I doubt that it's related to AV software - I suspect it's far more likely related to Rider trying to fetch the current values of every variable visible in the source editor… but that's just a guess.

0

I am still facing the issue and unable to dubug or run my project!

0

Please sign in to leave a comment.