Debug with docker compose: Build args are ignored in docker files


I see that when I try to debug docker-compose, rider starts ‘Background Tasks’ where it pulls images. 

At this phase, it seems that it ignores the build args given to it and just pulls any image of the requested image (since it didn't read the argument which specifies which version is required). 

For example: "Pulling image…"

Is this a know issue? How can I overcome this? 

I cannot debug till it finishes, and it is not logical for me to let it download all versions, since it takes a lot of time and takes up a lot of time and it is not needed. 

Note 1: I'm on a mac.

Note 2: I've verified this by specifying the exact image version in the docker without injecting it via ARG and it worked. 

Note 3: I am able to build and run successfully outside of rider (i.e. command line, Visual Studio)


Hello Boris,

Thank you for contacting Rider support.

Regrettably, I was not able to reproduce the issue. I would appreciate it if you could share more details on what you are doing. How exactly do you pass the version of image as a build argument?
Image version can be set either in Docker file nor in docker-compose file. 

Would you mind sharing a screencast that demonstrates the issue?

Thank you in advance and have a nice day!


Hi, I've opened a bug on this in youtrack and the team has already addressed it and fixed it. I see that it shall be included in the next build. Thank you. 


Please sign in to leave a comment.