How to turn off CSharpCopyPasteAssist (some sort of automatic smart paste)

Every time I copy paste something like [SerializeField] attribute onto a field that has xmldocs above it, the attribute gets commented out, and I don't want that to happen.


Another thing that happens is when I copy paste xmldoc into another field (to use as a template since the documentation for the other field will be similar), all the “<” turns into "&lt;" and all the ">" turns into "&gt;" completely messing up the xmldoc tags. I don't what that to happen. I really want to curse but I'll keep this post PG.


I can see in the undo history that the thing responsible for this is something called “CSharpCopyPasteAssist.EscapePa…”

Searching that in the Settings window returns nothing. Googling it returns nothing. How do you turn it off?

I can see that using “Paste as Plain Text” circumvents this issue but the assigned keyboard shortcut is incredibly awkward (Shift + Option + Command + V). As a workaround, I have changed “Paste” to Option + V and “Paste as Plain Text” to Command + V. But these default keyboard shortcuts are crazy.


So just to clarify, “Paste as Plain Text” is only a workaround, and doesn't solve the issue because using that, now I lose the feature that automatically indents the text properly upon being pasted (referring to the setting “Auto-format on Paste: Indent”).


In previous versions, you may see a pop-up window which will ask if you want to apply "Smart Paste" in editor. 

May I know if you can paste correct content by pressing “Command + Z” to undo the auto-escape operation?

We have an issue for this unexpected behavior on YouTrack. 
RSRP-494101 Automatic escape when copy-pasting inside documentation comments
You may try with latest EAP version see if the fix is working to you.



Please sign in to leave a comment.