Revert New Terminal config on Mac (EAP)

I don't know when, why or where something changed. But the Terminal in Rider now keeps a separate input window the commands. The commands are then sent to some “text view” that renders the result.

There has also been an addition of autocomplete tooltip popups that are very annoying. I can't focus on what I'm typing since these popups are constantly flashing and changing.

I've looked around for some settings on this behaviour but can't find any. Anyone have an idea on how to revert to “old behaviour”, where it was simpler and less cluttered?


Hello Daniel,

To disable the new terminal, please disable registry key. For that, open "Registry..." dialog via "Help | Find Action...".


Works great, thank you <3


Please sign in to leave a comment.