Issues with viewing Perforce type time-lapse not working in Rider.

Hello, I am currently using Perforce as a version control tool. I can't see the Perforce type time-lapse views in Rider. Is there a setting that needs to be changed?

Here are my settings:

  • Rider - Settings - Version Control - Perforce
    • Charset: utf8
    • Path to P4 executable: p4
    • Path to P4VC executable: p4vc

I am using the Helix program with the version Rev. P4V/NTX64/2023.4/2558838.

When I attempt to view the time-lapse, I get the following error: "Failed to run p4vc: Cannot run program 'p4vc': CreateProcess error=2, the specified file cannot be found. Please make sure that the Perforce Visual Client is installed and available in the path."

If I change the p4vc settings to the installed p4vc.bat path, "C:\Program Files\Perforce\p4vc.bat," the Helix program gives me the following error:

"Unicode server permits only unicode enabled clients."

The Perforce command run was: [p4 annotate -a -q -t -c -dl //okdepot/{Path}]

How can I make it work correctly in Rider?

1 comment


This seems to be an issue indeed:

Does it help if you set charset via terminal: “p4 set P4CHARSET=utf8”

Also, do other perforce actions work? 



Please sign in to leave a comment.