Configure color for gutter markers showing code coverage?

I can't seem to figure out how to make the markers showing in the gutter, the ones that indicate code coverage, change color.

All leads point to Editor → Color Scheme → General → Line Coverage, and then change the color of Full, Partial, Uncovered.

But no matter which colors I choose here, the actual colors being used are washed out gray and brown colors, which for my color blindness, is … somewhat less than ideal.

Is this the right place to configure these? I searched the settings for coverage, and can't seem to find other settings for the color of these things, but clearly the settings I found do not apply.

Can anyone advise?

1
5 comments

It seems that in Rider 2023.3.4, the “fully covered” color is bright, the two others are muddy green, and in 2024.1 EAP-RC, they're all a variation of muddy green.

1

This is rather unhelpful:

The colors I have configured are:

* Full: Foreground = 00FF00 (bright green)

* Partial: Foreground = 363628 (dark yellow/brown)

* Uncovered: Foreground = FF0000 (bright red)

I have tried foreground, background, error stripe mark, effects, none of it seems to matter in 2024.1 EAP-RC.

At least in 2023.3.4, the fully covered is somewhat brighter, but I still can't configure it.

1

Same problem here.  Why change these colors to such dark, similar colors?  It makes it much more difficult to see what is covered.  This issue, along with losing a bunch of my custom live templates, has made this update one I wish I would have not installed.

1

Hello folks,

The new colour scheme indeed became less readable in dark themes, see DCVR-12419 for updates on this. 

The setting to configure coverage highlighting at File | Settings | Editor | Color Scheme | General | Line Coverage is indented for Java coverage in Rider. dotCover is yet to support configurable highlighting. I have created a feature request to fill this gap. Please vote for DCVR-12524 Make highlighting colours configurable.


 

0

An alternative workaround can be to enable “shaped markers (colorblind mode)” to show the differences better:

File > Settings > Build, Execution, Deployment > dotCover > Highlighting

0

Please sign in to leave a comment.