Suddenly Unable to Debug x64 Projects

I am running Rider 2024.1.1. This is in a Windows 11 ARM virtual machine (Parallels on Mac). Earlier this afternoon, Rider is suddenly unable to launch the debugger when I try to debug any .NET Framework 4.8 projects with the x64 build configuration. The project builds without error but the button to start debugging in the toolbar spins until I get a notification saying “Debugger worker was not initialized within 100,000 ms”. 

This is only happening in the x64 build configuration. The process starts up and the debugger attaches without issue if I switch to the AnyCPU configuration, but we have a few libraries that only work on x64 so that workaround is not an option. I can also launch projects in x64 but not in debug mode from Rider.

This started happening and I can't seem to figure out what's changed. I was able to debug a process one minute (in x64). I stopped it. And tried to run it again, and it failed to start. 

I have tried: Restarting Rider. Restarting the VM. Restarting the Host machine. Reinstalling Rider. Invalidating Rider caches. Building from a fresh clone of the repository. Repairing the components of the Visual Studio installation. Using a fresh Windows VM image (and therefore fresh installation of Rider and VS).

Debugging in Visual Studio works in x64. So I'll probably be doing my work there for now. But in the meantime, is there anything I can look into to figure this out, such as crash logs? Or is there any way to increase the Debugger worker initialization timeout?

I realize that developing .NET Framework 4.8 for x64 on an Windows 11 ARM VM on a Mac is such a niche working environment and there's probably very little support out there. Any help would be greatly appreciated.

2
7 comments
Hello,

Thank you for contacting Rider Support. To take a closer look at the issue, we will need some additional information. Please do the following:
- Go to Help | Diagnostic tools | Choose Trace Scenarios 
- Enable the Trace scenario for debugger;
- Reproduce the issue
- Collect the full log bundle via Help | Collect Logs and Diagnostic Data, 
- Disable Trace scenarios;
- Attach the resulting log bundle to this ticket or upload it to our server (https://uploads.jetbrains.com/) and share the ID.

Thank you in advance and have a great day!
0

Thank you Sofia!

I've uploaded the logs and diagnostic data and the ID is 2024_05_01_PCFnRDfv6cTJuK2Wb6Npmp.

0

I have the same problem. Currently, I downgraded to version 2023.3.3.

0

Thank you Asapojnik for reporting that. I was able to debug for a few days with 2024.1, and then it suddenly stopped working, so I didn't think to try an older version. I tried 2023.3.5 and it worked for me. I saw they released 2024.1.2 this morning. Tried it and was still unable to debug. 

1

jasperreddin Unfortunately, it looks like you have faced a known issue on Windows arm versions: 

RIDER-111096 Attach to Process Fails with "Debugger worker was not initialized within 100,000 ms". 

I can reproduce the problem with my PD + Win11 environment as well, we are currently investigating the root cause of the problem. 

We would appreciate it if you would upvote it to bring increased awareness to the issue. One can also click `Watch` to monitor the status.

0

Same for me. Debugging an x64 process on Windows 11 ARM64 (Microsoft Windows Dev Kit 2023) does not work using Rider 2024.1.2. Rider 2023.3.5 works.

0

Same for me. Debugging an x64 process on Windows 11 ARM64 does not work using Rider 2024.1.2. Rider 2023.3.5 works.

0

Please sign in to leave a comment.