Markdown rendering crashes Rider on Ubuntu 24.04

Hi,

Just updated Ubuntu to 24.04 last weekend. I use Rider, PhpStorm and WebStorm most of the time. I noticed, when opening any of these IDEs, that they crash immediately after opening any project. I tried the versions installed through Toolbox, Flatpak and Snap but all behave the same. I tested with my Lenovo work laptop and my Dell XPS 15 private laptop, but the problem occurs on both.

At first, I did not see what went wrong, because for some projects the problem did occur and for some not. I noticed the problem when I opened a Markdown file manually that the IDE crashes. When the project has a README.md file and is opened for the first time, it crashes immediately.

About window info:

JetBrains Rider 2024.1.1
Build #RD-241.14494.325, built on April 16, 2024
Licensed to X
You have a perpetual fallback license for this version.
Subscription is active until June 27, 2025.
Runtime version: 17.0.10+8-b1207.12 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.8.0-31-generic
.NET Core v8.0.1 x64 (Server GC)
GC: G1 Young Generation, G1 Old Generation
Memory: 3978M
Cores: 16
Registry:
 ide.experimental.ui=true
 ide.new.project.model.index.case.sensitivity=true
Non-Bundled Plugins:
 com.intellij.plugin.adernov.powershell (2.6.1)
Current Desktop: ubuntu:GNOME
 

I am curious what the problem might be, as I have noticed it on 2 different Ubuntu 24.04 installations. Also don't know if the problem is already known.

3
9 comments

I think I am experiencing the same issue, Rider will crash shortly after the README.MD tab is rendered. Also on freshly installed 24.04.

Interestingly, VS Code also freezes directly in the same repositories.

1

Can confirm the following workaround:

  1. From the start screen, select Configure > Settings
  2. Under “Advanced Settings”, disable “Open README.md file if there are no open files on project startup”

This way, Rider will load my projects (but still crash if you manually open a markdown file).

0

I'm also encountering this issue with Rider on Ubuntu 24.04, where opening the Readme.md file at the root of a mid-weighted solution causes a crash. If I remove the Readme.md file and then start Rider, opening any other file leads to an incremental increase in RAM usage, and causing a system crash. As a temporary workaround, disabling globally the Solution Wide Analysis allows me to code with reduced functionality.

0

I have the same issue in Webstorm. this is probably a bug affecting all Jetbrain apps

0

Same here under Ubuntu Unity 24.04 both with WebStorm and IDEA Ultimate :/

0

Hello,

It seems you encountered a known issue. We have the following similar reports on our tracker:

As a workaround, please try this:

  • Add -Dide.browser.jcef.sandbox.enable=false to IDE vmoptions file:
  • Find and open the ~/.config/JetBrains/<product><version>/<product>.vmoptions file;
  • Add the mentioned entry to the end of the file;
  • Check if that helps;
  • If you use ToolBox, you can access the .vmoptions file from IDE settings:

We hope to implement a fix for this from our side in future releases.

Have a nice day!

3

I'm not quite sure what went wrong (or correct in this case, haha), but opening and rendering a markdown file now seems to be working correctly. Tested with WebStorm, Rider and PhpStorm. The error still occurs in PhpStorm, but does not occur anymore in WebStorm and Rider.

These is the IDE data:

JetBrains Rider 2024.1.2
Build #RD-241.15989.179, built on May 6, 2024
Licensed to x
You have a perpetual fallback license for this version.
Subscription is active until June 27, 2025.
Runtime version: 17.0.10+1-b1207.14 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.8.0-31-generic
.NET Core v8.0.1 x64 (Server GC)
GC: G1 Young Generation, G1 Old Generation
Memory: 3978M
Cores: 16
Registry:
  ide.experimental.ui=true
  ide.new.project.model.index.case.sensitivity=true
Non-Bundled Plugins:
  com.intellij.plugin.adernov.powershell (2.6.1)
Current Desktop: ubuntu:GNOME
WebStorm 2024.1.2
Build #WS-241.15989.105, built on April 23, 2024
Licensed to X
You have a perpetual fallback license for this version.
Subscription is active until June 27, 2025.
Runtime version: 17.0.10+1-b1207.14 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.8.0-31-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 3978M
Cores: 16
Registry:
  ide.experimental.ui=true
Current Desktop: ubuntu:GNOME
PhpStorm 2024.1.1
Build #PS-241.15989.102, built on April 23, 2024
Licensed to X
You have a perpetual fallback license for this version.
Subscription is active until June 27, 2025.
Runtime version: 17.0.10+1-b1207.14 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.8.0-31-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 3978M
Cores: 16
Registry:
  run.processes.with.pty=TRUE
  ide.experimental.ui=true
Current Desktop: ubuntu:GNOME

The workaround with the .vmoptions file works fine with PhpStorm, so at least I can open and edit .md files in JetBrains tools again.

0

Hello Duco,

I am glad to hear that the workaround helped.
Should you have any other questions or difficulties, do not hesitate to contact support.

Have a nice day!

0

I upgraded to 24.04 on Friday and experienced this problem on Goland, Webstorm, CLion, and PyCharm.  The fix that Dmitry Kazantsev recommended worked on all products.

0

Please sign in to leave a comment.