Rider not showing excluded flies in different colour

Since I've upgraded to 2024.1, the Solution pane is no longer showing files excluded from the project in a different colour.  The excluded files *do* appear because I've clicked the “Show all files”…they're just not highlighted.   If I r-click the excluded file, I can indeed see “Include”, so I know it really is excluded. I've searched through the settings, and can't find a setting for this. I've changed themes, but the problem persists through all themes.

1 comment

Please have a try with delete the .idea folder in solution root folder to see if the problem could be mitigated. 

In Settings | Appearance & Behavior | File Colors, you can enable and change the scopes. See if you have color assigned for the “Non-Solution Files” scope.

If the issue persists, please share your color theme settings (use the default settings) and provide a screenshot of the issue.


Please sign in to leave a comment.