Toolchain issues with Unreal Engine 5

“UnrealBuildTool has banned the MSVC 14.39.33519-14.39.99999 toolchains due to compiler issues. Please install a different toolchain such as 14.38.33130 by opening the generated solution and installing recommended components or from the Visual Studio installer.”  I have the proper build tools, and rider is pointing to them. It does not matter which of these options I select, I am constantly met with the above error.  I've reinstalled everything from scratch, paying careful attention to the directions, and for 5 days I have been unable to make rider usable with Unreal Engine 5.  I'm beginning to think it is impossible to use rider with UE5.


I also get:

Failed to build RiderLink plugin for C:\Program Files\Epic Games\UE_5.4
Failed to build RiderLink plugin

when trying to install the riderlink plugin


I dont know a lot about ryder but I found your issue because I had the same in visual studio and I uninstalled MSVC latest and installed version 14.38-17.8 and it worked maybe there is something similar to do in ryder?


Got the build tools and now I'm getting different errors:

LINK: Error  : LNK1181: cannot open input file 'delayimp.lib'

Which the internet says is another build tool version issue.   In the past, rider has told me to install this exact version, and now that I do it throws me new issues.


Fixed it, wish I knew how but I have no clue


I found this thread by broadly searching the error “unrealbuildtool has banned the msvc”.

I had the latest version installed (14.39) and was getting this error on a newly created 5.4 project derived from Lyra. I uninstalled the current MSVC and installed the one recommended in the UnrealBuildTool log (14.38); relaunched the project in rider and it loaded and compiled.



Thank you, Mackenzie.

Other developers also experience the same issue with the latest MSVC compiler installed. Unreal Engine 5.4 release notes say the preferred compiler version is 14.38. So the solution here is to install MSVC 14.38-17.8.

There are several complaints on that on the Epic Games forum. Also, there were similar occasions in the past.

Have a nice day!



For anyone in the future. I got both issues,  and the " LINK: Error  : LNK1181: cannot open input file 'delayimp.lib'" was so annoying.

I was able to solve this issue by just removing every one of the MSVC components that I had installed, and then installing this one ( the most similar to the recommended 14.38.33130 )

After that, I built my UE project with Rider and it was successful


I got this same problem, but only after upgrading Unreal Engine from 5.4 to 5.4.1. Everything worked nicely in 5.4. After installing build tools v14.38-17.8 it seems to work again. I did not uninstall anything, I only added the specified version package.


Same issue tried all above, next  i will remove vs 2022 and install 2019. see if that works.

Hello Axisstargazer,

What the engine version do you develop with? Are you getting the “UnrealBuildTool has banned the MSVC 14.39.33519-14.39.99999 toolchains due to compiler issues" error even after installing build tools v14.38-17.8?

Please sign in to leave a comment.