Debugging or Running stuck on "Background Tasks"


For nearly a month, I haven't been able to properly use Rider to debug or run my project. I'm encountering an issue where the "build project" task seems to be stucked and cannot be interrupted. I've tried the following methods to resolve the problem, but none of them have worked:

  • Upgrading to the latest version of Rider (2024)
  • Uninstall and reinstall everything of Rider
  • Cleaning the solution and rebuilding in Rider
  • Deleting UE5-related files and regenerating the VS files
  • Attempting to build the same UE5 project using Rider on another Windows 11 PC

I can debug and run in VS2022.

I have tested in both 2023.3 and 2024.1, both them have the exactly same issue.

Here is my PC info:

JetBrains Rider 2024.1.1
Build #RD-241.14494.325, built on April 16, 2024
Licensed to M X
Subscription is active until March 8, 2025.
Runtime version: 17.0.10+8-b1207.12 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 11.0
.NET Core v8.0.1 x64 (Server GC)
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 32
Non-Bundled Plugins: (241.14494.150) (241.14494.320)

The picture shows where I am stucking while debugging or running the project.


Hi, what's the final result of building the project? Or it will just get stuck and never finish?

If the process is not crashed but always not responding, you could refer to the “Rider.Backend process is hanging” section in this article, collect several process dumps (about 2~4 dumps) of the hanging Rider backend process (perform a collection every few seconds, so I can observe the changes in thread status), I will help to check it further.

Please compress your dumps and upload to this link, share the upload ID, thanks.


Hi Sun,

Thanks for the response!

The final result is “just get stuck and never finish”.

The dumps I collected which are:

  1. Before debugging 
  2. debugging
  3. debugging
  4. canceling the background task in Rider:

Please check the dumps file with the upload id: 2024_05_13_JF1JeM8dDoWTibXpXxrZEi




It seems the 3-rd party VPN library (ASProxy64.dll) is injected into the Rider backend process. 

Please try to stop/remove the software to see if there is any improvement.

JetBrains provides services and support for customers living in Mainland China, for more information, please visit our China official site

JetBrains提供面向中国大陆用户的服务,因此您应无需额外步骤来访问我们的站点及服务。相反的,如果你在访问JetBrains的服务时遇到了连接或稳定性问题,可以随时与我们支持团队联络(在IDE中,于 Help | Contact Support 处提交工单)


Hi Sun

You are my hero! It works after I uninstalled Astrill VPN.

Can I ask why the VPN could stop Rider backend process working?

What other softwares or what kind of softwares might influence Rider just in case this happens in the future again.



Honestly, I don't know why the proxy software needs to be hooked on the Rider process. Rider will not invoke external libraries proactively, so it more looks like an issue caused by the VPN itself.

I can see many similar problems on the Internet about Astrill VPN injecting other processes, so it should be a common issue of the software.


Please sign in to leave a comment.