Your WASM app is getting ready to be used by Rider debugger, please stand by...

I have a Blazor .NET 8.0 web app. When I try to debug it in Rider, it sometimes works. But more often, it just opens a Chrome window with blanks screen with the following text in the middle: “Your WASM app is getting ready to be used by Rider debugger, please stand by…”. It doesn't help to stop debugger or re-run, close the browser etc. However, restarting Rider helps. Any chance to solve it?

1
8 comments
Hello,

Thank you for contacting Rider Support. 

It sounds weird. Unfortunately, I can't reproduce such an issue. In order to take a closer look at the issue, we will need some additional information. Please do the following:
- It would be very helpful if you could make a recording that demonstrates the issue!
- Go to Help | Diagnostic tools | Choose Trace Scenarios;
- Enable the Trace scenario for Debugger;
- Reproduce the issue;
- Collect the full log bundle via Help | Collect Logs and Diagnostic Data;
- Disable Trace scenarios;
- Upload the resulting bundle (and recording) to our server (https://uploads.jetbrains.com/) and share the ID.

Thank you in advance and have a great day!
0

I have the same problem on my system. I've collected the logs and uploaded as Upload id: 2024_06_14_23B3pShbDQwUmQb37aytJm (file: rider-logs-20240614-1038511898539426504398884.zip)

0

My upload Id: 2024_06_15_VKZPeFhTtW4MVa6skiwZhF

0

Hello Johan,

Thank you for reporting your issue. We see the problem from the logs. We hope to fix your case. There is a bug report for your case: /RIDER-113774 Can't debug Blazor .Net 8 project. 401 when checking if page is available for debugging.

Hello Bea,

Thank you for the logs shared. Your case is probably already fixed in the EAP version. Would you mind trying this and letting me know if that helps?

If that doesn't help, we would appreciate it if you could share either your project (if possible) nor the .csproj (for all 4 projects in solution or at least BleafSample.Client.csproj) together with corresponding launchsettings.json file.

Note: your uploads are not publicly available. It is only available for JetBrains employees. Also, we can sign an NDA. If sharing a project or those files without signing NDA, the issue persists in EAP and you are interested in troubleshooting the case, please let me know.

Have a nice day!

0

The Rider EAP does not solve the issue. But I found a workaround: before hitting debug, close all browser tabs with Blazor and kill ".NET Host" background processes in Windows Task Manager. Usually last one is not killable but that's ok. 

0

Hello Bea,

We are glad to know you found a workaround. It seems Rider doesn't kill some process which unexpectedly remains alive and prevents Rider from launching another one. 

We would appreciate it if you could take a closer look at this issue and share more information, so that we can take a closer look on our side:

  • Take a closer look at the processes you kill in order to workaround the issue. We are interested in exact command line of these processes and parent pids. Also, please check who is the parent processes. You can use, for example, Process Hacker or Process Explorer;
  • Try narrowing down killing which process solves the issue (Kill processes one by one and try launching Debug every time you killed a process);

Have a nice day!

0

After normally finishing a debugging session in Rider (pressing the red square button at the debug toolbar), the following .NET Host processes are present (info from Process Hacker):

dotnet.exe, 12736, "C:\Program Files\dotnet\dotnet.exe" "C:\Program Files\dotnet\sdk\8.0.302\MSBuild.dll" "C:\Users\User1\AppData\Local\Temp\Jidokip.proj", 0,03, 24 B/s, 179,35 MB, B-PC\User1, .NET Host
dotnet.exe, 4260, "C:\Program Files\dotnet\dotnet.exe" "C:\Program Files\dotnet\sdk\8.0.302\MSBuild.dll" "C:\Users\User1\AppData\Local\Temp\Rucepuj.proj", 0,05, 24 B/s, 24,73 MB, B-PC\User1, .NET Host
dotnet.exe, 16828, "C:\Users\User1\AppData\Local\Programs\Rider\lib\ReSharperHost\windows-x64\dotnet\dotnet.exe" exec --runtimeconfig "C:\Program Files\JetBrains\Rider\r2r\2024.1.3R\01DDFA199F9AD2E2682D754E56497A7\JetBrains.Roslyn.Worker.windows.runtimeconfig.json" "C:\Program Files\JetBrains\Rider\r2r\2024.1.3R\01DDFA199F9AD2E2682D754E56497A7\JetBrains.Roslyn.Worker.exe" 54913 9008, , 24 B/s, 89,9 MB, B-PC\User1, .NET Host

All processes are children of Rider.Backend.exe. At this point, trying to launch again Rider debugger always fails, as I described before.

The workaround that I found is to terminate these processes. I only managed to do it efficiently directly from Task Manager. It may take a few tries to terminate a process because new ones may spawn in place of terminated ones. But eventually they can be terminated, if done from Task Manager (from Process Hacker they respawn forever..). Finally, the last process will always spawn new one if terminated even from Task Manager, but as I mentioned debugging works at this point.

The last proces that survived but did not prevent debugger from launching was:

dotnet.exe, 18144, "C:\Program Files\dotnet\dotnet.exe" "C:\Program Files\dotnet\sdk\8.0.302\MSBuild.dll" "C:\Users\User1\AppData\Local\Temp\Viwexow.proj", 0,02, 24 B/s, 178,31 MB, B-PC\User1, .NET Host

It has different PID but as I said, this is a (grand) spawn of some original one.
 

0
Hello Bea,

Thank you for your for your analysis! Apologies for taking so long to respond.
Unfortunately, we are now even more confused. These processes should not impact debug launch.

We need to reproduce this issue in order to troubleshoot it. Did you try reproducing this issue with a newly created project? Or does the issue only occurs on your main project?
If you could reproduce the issue on a new project that mirrors your main project structure, that would be very helpful! If it is too much for you, would you mind sharing the BleafSample.Client.csproj file together with corresponding launchsettings.json (feel free to obfuscate its content)?

Note: also, there is an option to sign an NDA so that you can share you project with us.

Have a nice day!
0

Please sign in to leave a comment.