Why do I get iOS build issues when simply trying to deploy to Android?

I feel like this problem only surfaced with MAUI. And I've seen it in Visual Studio as well, so it's not necesarilly a Rider issue. But I'm using Rider now, so I thought I'd post it here:

My project just got upgraded to .NET8 and now it wants an Xcode upgrade. Fair enough. But why can't I still build and deploy in Android and fix this feature later? 

As far as I know, the only way to get around this is remove all references to supporting iOS, but that's a huge can of worms having to go through every project in my soution. 

And yes, I will upgrade my Xcode. But I just didn't use to have to do this while I worked on Android before.

1 comment
Official comment

Hello Cfin ,

Thank you for reaching Rier Forum.

Unfortunately, at the moment in the build stage, all platforms are built. Thus, the issue you have faced is a bug with ID RIDER-91070 Running Android Run Configuration also Builds other TargetFrameworks. At the moment it is being worked on by our team. You may want to upvote it to receive news on the matter. 

I hope my reply was helpful. Have a nice day!

Please sign in to leave a comment.