Ubuntu 14.04: Rider host has unexpectedly exited; ReSharper and Project Browser aren't working

Completed

Everything was OK with the previous version! Now just after the IDE launch the message appears:

Oops, Rider host has unexpectedly exited with exit code 0.
See ~/.Rider10/system/log/backend.err

The file above contains this text (I've left only exception messages, without traceback):

There was an unexpected error when loading an existing DeployedPackagesCache for ProductBinariesDir /home/ms_lilibeth/opt/riderRS-163.5065/lib/ReSharperHost. Cannot find central directory

Failed to load the Package Metadata File JetBrains.Platform.Core.Ide.JetMetadata.sstg from disk. The type initializer for 'ICSharpCode.SharpZipLib.Zip.ZipConstants' threw an exception. Encoding 866 data could not be found. Make sure you have correct international codeset assembly installed and enabled.

Failed to load the Package Metadata File JetBrains.Platform.Core.Shell.JetMetadata.sstg from disk. The type initializer for 'ICSharpCode.SharpZipLib.Zip.ZipConstants' threw an exception. Encoding 866 data could not be found. Make sure you have correct international codeset assembly installed and enabled.


Failed to load the Package Metadata File JetBrains.Platform.Core.Text.JetMetadata.sstg from disk. The type initializer for 'ICSharpCode.SharpZipLib.Zip.ZipConstants' threw an exception. Encoding 866 data could not be found. Make sure you have correct international codeset assembly installed and enabled.

e t.c.

Is this my fault? Why did it failed to load these packages?
All prerequisites are installed and recently updated.


2 comments
Comment actions Permalink

I have the same problem as you.

0

Please sign in to leave a comment.