Adding Mono 2.0 runtime for Unity in Windows


I wanted to add the Mono 2.0 runtime in the hopes that the IDE's compiler feedback would be consistent with Unity's. Unity bundles a Mono runtime, so I first tried to add that, but was unable. Then I installed Mono 2.0 directly and tried to add that, but was also unable. In both cases, it appears to be a simple matter of executables not being where Rider expects them to be. I tried selecting different folders to "add" to no avail. Error messages are variants of this in every case:


Cannot detect any runtime at C:/Program Files (x86)/Mono-2.0: Could not find a part of the path 'C:\Program Files (x86)\Mono-2.0\lib\mono\xbuild'.

--- EXCEPTION #1/1 [DirectoryNotFoundException]
Message = “Could not find a part of the path 'C:\Program Files (x86)\Mono-2.0\lib\mono\xbuild'.”
ExceptionPath = Root
ClassName = System.IO.DirectoryNotFoundException
Source = mscorlib
StackTraceString = “


I have a similar issue with the Mono for Unity on OSx.

In /Applications/Unity/ I added a symlink to xbuild:

ln -s bin/xbuild lib/mono/xbuild

But when adding "Applications/Unity/" as a Mono runtime folder I simply get this informative error: "The directory name is invalid"



We have checked the possibility to use mono 2 - unfortunately it is not possible at all.


Please sign in to leave a comment.