Anyway to customise code style?

Completed

Either with an xml file or a hack or something, I really want my brackets K&R Style! :)

11 comments

Not really supported, but if you want to try and modify the XML files, here is information on them:

 

https://www.jetbrains.com/idea/help/project-and-ide-settings.html

0

If you have Resharper, you can export "team shared settings" (sln.DotSettings) for these, and Rider seems to respect them. I had to change the tab size from 4 to something else and then back to 4 before it respected that setting, though.

1

Greg you're a genius, it worked!

0

Any hints for those of us without ReSharper? The documentation link appears to be dead. Pasting a demonstrative XML file would be of great help.

0

As far as I can tell it's a very bespoke schema, happy to share mine though by all means.

check this file : https://bitbucket.org/quickfingerz/unicycle/src/eeba32cc2292bfcd163e6bfef24b975803b9c0b4/SyncRiderProject.cs?at=master&fileviewer=file-view-default

and near the bottom the multi line string callied resharperSettingsFile is my dotSettings file 

2

Awesome, thank you! I took the liberty of posting the DotSettings part as a gist, I hope you don't mind.

https://gist.github.com/JavadocMD/452fd33a7d8171e03acf

For the benefit of others: all I had to do was put that file in the same directory as the .sln file. I imagine you'll have to adjust the name to match your project.

0

Yeah no problem at all dude. And yes naming must be exactly the .sln name + .dotSettings and in same location as .sln file.

so if your sln file is called mycsproject.sln, then this file should be called mycsproject.sln.dotSettings and rider will read it like a champ

0

Hey,
Can someone explain me how to use the files ?
Thanks

0

Thanks for the workaround. Note I had to put my settings in a file with a ".user" extension i.e. `solutionName.DotSettings.user`.

0

Note, while this work, it won't help with changing style for private fields from _lowerCamelCase (default in Rider) to lowerCamelCase (default in R#).
Even if you add it to your setting file (the R# default aaBb) it won't be picked up by Rider (AaBb will), I guess Riders as well as R# sees that it is the default, only problem is that it isn't really default for Rider which (at least currently) have aaBb with a leading underscore as default

0

Please sign in to leave a comment.