Where's the executable?


I've Googled around but didn't find where the compiler outputs the executable?  Anyone know Rider is outputting the executable when compiling on OS X?




It should be in the output path that is mentioned in the 


You can see this in the project file if you jump to code (right click or whatever that is on a mac to pop the menu then its an option in there). The path should be relative to the project location. I am having an issue where the compiler is not finding this variable in Windows 10. I assume its using MSBuild to build in Windows since I have it installed. It seems configs are different in rider as well so maybe I am setting this up wrong. This is new to me since I am coming from the VS world.


I'm having the exact issue as reported, did anyone get to the bottom of this? using mono from the command line is more than happy but there are no executables when building through rider (in the defined OutputPath)



Please help me understand the problem.

On MAC I have tried 
1. Change OutputPath from bin/Debug to bin1/Debug and then ReBuild
2. I made a right click on Project in SolutionExplorer and call CopyPath from context menu
3. In Finder Command+Shift+G paste path, remove the filename, enter
Path is opened in Finder. Then check that the bin1/Debug/ConsoleApplication1.exe exist. So for me it fully worked.


I realised that my issue was only happening on rebuild and therefore fell back onto build, which produced build output in the correct location. At the time I had a suspicion that there was a rogue clean being carried out after the fact as the build log registered the correct output paths.

Having just been forced into an app update I have run both Build and Rebuild with both working as expected. 


Please sign in to leave a comment.