Customize color themes

Answered

Hi,

I have tried to modify colors, making is similar to Sons of Obsidian theme, but the changes didn't apply to the project (Unity proj, C#).
Is it an issue or feature under development?

11 comments
Comment actions Permalink

I've had the same issue - some color settings seem to apply, but mostly they get ignored.

0
Comment actions Permalink

Hi guys! Try adjusting `All Rider Defaults' color settings page this will help.

However I too find the inability to adjust settings from General or Language Defaults pages a bit frustrating. We're working on merging R# and IDEA highlighters in settings. 

I hope to fix this prior to the next EAP.

0
Comment actions Permalink

Moreover, I think the fix will help to use exicting IDEA schemes in Rider as is or with minor modifications

0
Comment actions Permalink

Thanks Alexander - fixing it in `All Rider Defaults` has definitely made a difference.

Looking forward to the next EAP!

0
Comment actions Permalink

I didn't get what is "All Rider Defaults" and where it is..

0
Comment actions Permalink

Hi,
Thanks for reply. 
I just received info letter about new Rider version release. Look like color schemes added there.. But not clear how to add them. 
The only what I get is that window , and it's not possible to drag jar. scheme there

What did I miss? 

0
Comment actions Permalink

Hi!

Select «File» → «Import Setting» from the main menu and follow the instructions. After the IDE restarted go to the Preferences, expand «Editor» → «Colors and fonts» tab and choose the installed theme.

http://color-themes.com/?view=help 

0
Comment actions Permalink

Hi, 
Thanks, that works. You made good changes, but 1 found issue here - if you change colors in class tab, that doesn't affect to opened .cs files. Only reopening or writing new code helped
http://take.ms/90xeC

0
Comment actions Permalink

I'm still having problems with this and I don't have an "All Rider Defaults" options.  In particular, I cannot get the "Tag Name" for "ASP.NET" to stick.  No matter what I put, it always shows up dark red.

0
Comment actions Permalink

This issue related to an old version and now should be resolved. 

Please, contact us if you still have this issue or in case of any other questions or problems. 

Thank you! 

0

Please sign in to leave a comment.