Can not create Xamarin Application in Rider (Linux platform)



I want use Rider (2017.3.1)to develop Xamarin Application(Android)

When I open new solution => Xamarin => Application  => platform => Android

the Framework will show " No Target  frameworks were found in the machine" , the " create " button can not be click !

I had setting Android SDK path in /home/username/Android/Sdk, the path is the same Android Studio.

(File=>Settings=>Build,Execution,Deployment=>Android=> Android SDK Path )

I also install Android Studio(3.0.1) and make sure I have Android SDK and can create Android App successful

How can I fix the problem ? thanks !!


I was getting the same error. Fixed it by making sure mono was in my PATH.


Hi Jean37

Can you show more detail info ? In terminal , I type mono and the shell will return mono info,so I think the mono binary in my  path

here are my path info

echo $PATH



I made a comment earlier which is pending approval because it has external url links.

I don't think Rider comes with the librairies. You have to install it yourself.



Same error here. How do you fix it?


I found this but it doesn’t really seem like this should still need to be done given Xamarin Android templates are right there in the IDE on Linux. Is it true that these extra steps have to be taken?


Has anyone being able to solve this issue please...


Ok, I was able to get this to build but when I try to run the app on a device I get the following error: Xamarin.Android.Common.targets(2465, 3): [MSB4018] /usr/lib/mono/xbuild/Xamarin/Android/Xamarin.Android.Common.targets(2465,3): error MSB4018: The "BuildApk" task failed unexpectedly.
System.IO.FileNotFoundException: Could not find file "/usr/lib/mono/xbuild/Xamarin/Android/lib/armeabi-v7a/"
File name: '/usr/lib/mono/xbuild/Xamarin/Android/lib/armeabi-v7a/'
  at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.Boolean anonymous, System.IO.FileOptions options) [0x0019e] in <2943701620b54f86b436d3ffad010412>:0
  at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share) [0x00000] in <2943701620b54f86b436d3ffad010412>:0
  at (wrapper remoting-invoke-with-check) System.IO.FileStream..ctor(string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)
  at System.IO.File.OpenRead (System.String path) [0x00000] in <2943701620b54f86b436d3ffad010412>:0
  at Xamarin.Android.Tasks.BuildApk.AddNativeLibrary (Xamarin.Android.Tasks.ZipArchiveEx apk, System.String abi, System.String filename, System.String inArchiveFileName) [0x0007f] in <b35ba8464b24408e961317cc2c367efa>:0
  at Xamarin.Android.Tasks.BuildApk.AddRuntimeLibraries (Xamarin.Android.Tasks.ZipArchiveEx apk, System.String supportedAbis) [0x00058] in <b35ba8464b24408e961317cc2c367efa>:0
  at Xamarin.Android.Tasks.BuildApk.ExecuteWithAbi (System.String supportedAbis, System.String apkInputPath, System.String apkOutputPath) [0x0009a] in <b35ba8464b24408e961317cc2c367efa>:0
  at Xamarin.Android.Tasks.BuildApk.Execute () [0x0032e] in <b35ba8464b24408e961317cc2c367efa>:0
  at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute () [0x00023] in <bdc5207a22bb42ae9fe3f3d07e82871e>:0
  at Microsoft.Build.BackEnd.TaskBuilder+<ExecuteInstantiatedTask>d__26.MoveNext () [0x00212] in <bdc5207a22bb42ae9fe3f3d07e82871e>:0 


Hi there!

Please, take a look at this guide about how to develop Xamarin.Android on Linux with Rider.


Kind regards,



Thanks Sofia! But it says I am not authorized to view that page.. 


Oh.. sorry!

Please, try now.


Thank you! You are doing God's work, Sofia! :) 


Hey Sofia,


I followed the guide but am still having some trouble. It's very strange the editor sees the using statements for Xamarin Android but when I got to build it complains that I don't have the Android SDK installed. Which I do.




I am running 18.04 but I don't think that should really be the issue and the fact that Rider allows the using statements with no error makes me think there's something missing. The project itself is just a File->New PRoject from Rider. Any help would be greatly appreciated.




      I am also unable to create Xamarin applications on (Arch) Linux: I get 'Android SDK is not found' in the project creation dialog. I have the Android SDK, OpenJDK, and Xamarin.Android all installed. I do not have a "Xamarin" entry under "Build, Execution, Deployment" in settings. Am I missing something? Do I need Oracle JDK for this to work? Something else maybe? I can create Android projects just fine in Android Studio.







Please make sure that you have Xamarin SDK installed.


The guide linked earlier in this thread ( still does not display because of the exact same authorisation error also mentioned earlier in this thread. Can an admin please make the guide publicly available?


Hi George,

Please check it now. 

It worth noting that this article was tested on SDK versions released in 2018. Therefore, you may face different issues during the latest versions installed, which this article does not cover.


Kind regards,



Please sign in to leave a comment.