No analysis has been performed (Document size has exceeded the threshold)

Answered

Some of our cs files are rather large, and I would like to enable analysis for them.  How do I increase the threshold that this error is talking about?

It appears at the top of the scroll bar with a pause symbol.

 

24 comments
Comment actions Permalink

Same problem for me, annoying situation. Trying to figure out if I can somehow increase the threshold.

There's something similar for CLion,still searching for Rider. 

https://www.jetbrains.com/help/clion/configuring-file-size-limit.html

0
Comment actions Permalink

Hello!

You can force analysis by moving the slider in the analysis indicator

2
Comment actions Permalink

Same issue. When I forced analysis, the status icon turned to green, but nothing changed in text editor. Types not highlighted, errors and warnings not underligned

0
Comment actions Permalink

I ran into this problem recently in Rider V 2020.2.2 when working with a large NSwag generated Client file.

I was unable to find any way to force inspections, either through searching with "Ctrl + Shift + A", or clicking the little "Off" icon. But i did find another solution.

What solved it for me was pressing "ctrl+alt+shift+8", as referenced here as "Toggle code inspection":  https://www.jetbrains.com/help/rider/Code_Analysis__Index.html#keyboard-shortcuts

This keyboard shortcut does not show up if you search for it in the Rider IDE, and neither does the "Toggle code inspection" action.

1
Comment actions Permalink

Have the same issue with the NSwag generated client. Is there a way to increase files size?

0
Comment actions Permalink

Sofia, that support link no longer works? Is there an updated link

0
Comment actions Permalink

Hi Cameron Beacham,

This instruction is no longer relevant and was archived.
If you have a file which is not analysed for a reason, you will see one of the following:

- Rider will show a notification:"BuildPsiFileSizeThreshold setting prevents analysis for big C# files." -> then you need to remove the setting <s:Int64 x:Key="/Default/PerformanceThreshold/BuildPsiFileSizeThreshold/=CSHARP/@EntryIndexedValue">300000</s:Int64> from DotSettings file. 

- Or you will be able to enable analysis for the file (with Highlight All Problems option):

 

0
Comment actions Permalink

Sofia Byzova

Hello.

This simply doesn't work. I need to refactor an old file that is ~400 kb in size.

Selecting 'All Problems' does nothing except highlights few SQL queries.

Not even errors, and I'm sure there is one (can't build the project)

Any fixes?

0
Comment actions Permalink

@Vyacheslav it is supposed to work with Rider 2021.1 EAP, are you on one of those?

0
Comment actions Permalink

Sorry for not replying earlier. I'm not sure what version I was on but I reinstalled Rider and feature is working properly now. Thanks!

1
Comment actions Permalink

Ivan Shakhov This does not work for me. Version info:
JetBrains Rider 2020.3.3
Build #RD-203.7148.23, built on February 17, 2021
Licensed to Blackbaud / Cameron Beacham
Subscription is active until August 20, 2021.
Runtime version: 11.0.9.1+11-b1145.63 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
.NET Core 3.1.8
macOS 10.15.7
GC: ParNew, ConcurrentMarkSweep
Memory: 1450M
Cores: 8
Registry: debugger.new.debug.tool.window.view=true, ide.tree.horizontal.default.autoscrolling=false, performance.watcher.sampling.interval.ms=200, ide.borderless.tab.caption.in.title=false, ide.tooltip.showAllSeverities=true, show.diff.preview.as.editor.tab=true, ide.mac.bigsur.alerts.enabled=false, debugger.show.values.use.inlays=false, light.edit.file.open.enabled=false, performance.watcher.unresponsive.interval.ms=1000, search.everywhere.settings=true, show.diff.preview.as.editor.tab.with.single.click=true, parameter.info.max.visible.rows=10, ide.win.file.chooser.native=true, vcs.log.show.diff.preview.as.editor.tab=true, actionSystem.fix.alt.gr=false, search.everywhere.pattern.checking=false, ide.tooltip.initialDelay=0, ide.balloon.shadow.size=0, ide.mac.bigsur.window.with.tabs.enabled=false, ide.require.transaction.for.model.changes=false, ide.debug.in.title=true, ide.new.project.model=false, rdclient.asyncActions=false
Non-Bundled Plugins: Abc.MoqComplete.Rider, Key Promoter X, com.chrisrm.idea.MaterialThemeUI, monokai-pro, com.microsoft.vso.idea, mobi.hsz.idea.gitignore, com.intellij.resharper.azure

0
Comment actions Permalink

@Cameron Beacham it is only expected to work in Rider 2021.1 EAP

0
Comment actions Permalink

We're running into this issue with version 2021.1.2.  Selecting "All Problems" on the individual files does show all the errors, but we really need a general solution.  Where would the "BuildPsiFileSizeThreshold setting prevents analysis for big C# files." message be showing up?  The only files with DotSettings in the names didn't have the BuildPsiFileSizeThreshold line mentioned to be removed.

Also, I just see "No analysis has been performed", no "(Document size has exceeded the threshold)".

0
Comment actions Permalink

@Mpurtill please create a new issue from Rider with 'Help - Report a Bug', agree to attach logs. Mention the new issue link here. Thank you!

0
Comment actions Permalink

I had the same problem with a just 300 kb file (2020.3.3). What in my case helped was to change to "Syntax" and then again to "All Problems". Now is working.

0
Comment actions Permalink

add line in GlobalSettingsStorage.DotSettings

<s:Int64 x:Key="/Default/PerformanceThreshold/AnalysisFileSizeThreshold/=CSHARP/@EntryIndexedValue">3000000</s:Int64>

This is applied to any project.

1
Comment actions Permalink

My toolbox installation of 2021.2 does not have the GlobalSettingsStorage.DotSettings file. The resharper-host directory only has directories named local, roaming and temp, so nothing like the image above. Am I looking in the right place?

Anyway, I put there the file found in the link above, but it does not cause a 400K source file to be analyzed. 

0
Comment actions Permalink

Does enabling via OFF daemon indicator (in the right top corner of the text control) work for you?

0
Comment actions Permalink

Unfortunately no.

Hovering over OFF shows this flyer, but moving the mouse hides it. Clicking on it has no effect.

 

0
Comment actions Permalink

Switch that Highlight:None into All Problems

0
Comment actions Permalink

I would like that very much, but the popup disappears as soon as I move the mouse...

0
Comment actions Permalink

When I move it inside the popup, it doesn't disappear for me. If it does for you, please report an issue with Help - Report a Bug, agree to attach logs.

0

Please sign in to leave a comment.