Rider hangs at end of splash

Completed

Not sure I have enough information yet to actually submit an issue on the tracker, but for the last couple of days, I have been unable to start Rider at all. At first, I figured it was just weird and that I misplaced the app, but now I see that it's a bit more than that.

When I launch the app, the program runs through the splash screen as normal, but stops responding when it gets right next to the end. Since it stops responding, the window gets hidden behind my other windows, and it doesn't have an entry when cycling through applications in alt-tab or in the taskbar.

Tracking this further, I followed the results to the logs, but I'm not sure quite what the cause is. It looks related to ReSharper as best as I can tell. I've got a .tar.gz of the logs that I can send in, as well.

Has anyone run into something similar, or might know a fix?
So far, I've tried uninstalling Rider and ReSharper and reinstalling them, and I've tried removing their configuration folders (%USERPROFILE%/.Rider$VERSION). Rider successfully reconfigures then launches the splash screen, loads, and stops responding again at the end.

Please sign in to leave a comment.