Xamarin iOS: Select Deployment Target dialog is empty


I have a Xamarin Forms project that I would like to develop in Rider. With Debug | Any CPU and Android Default run configuration, everything works fine - it launches a Select Deployment Target dialog with my installed emulators, and I can select one to deploy to. However, for iOS I can't seem to specify a Deployment Target with Rider, because the dialog is empty.

I am connected to a networked Mac (I work on a Windows box) using the Xamarin Mac Agent. I've tried in both Debug | iPhone and Debug | Any CPU, and I get the same behavior in both. In my Run Configuration for iOS Default, I have Target: Open Select Deployment Target dialog (I've tried using "Connected Device" with nothing for Name because nothing populates there, same result). If I select the Simulator option from the Target dropdown then the Name dropdown will populate with a bunch of different iPhones with different iOS versions, but Rider won't save the Run Configuration Target if I select Simulator - it just reverts to Open Select Deployment Target dialog (I suspect because I'm on a Windows box).

With Open Select Deployment Target dialog as my Target, when I go to run the configuration I get the dialog window but there's nothing in it. When I am connected to the same Mac in Visual Studio, I get a whole laundry list of devices and OS versions to pick from. I've tried Invalidating Cache and Restart, but that didn't do it.


Any feedback on how to get my devices to show up so I can see what my application looks like on iOS would be greatly appreciated.


I have the same issue. Help please



Same problem here.  I love Rider but this issue forces me back to Visual Studio for Mac.


Hi all.

Could you, please, check if the problem is reproduced in the latest 2018.1 release and EAP and that you have completed the following steps:

1. check if ssh connection allowed for your MAC machine (System Preferences | Sharing | Remote Login )

2. go to menu "Tools | iOS | Xmarin Mac Agent" 

4. In the popup window press "plus" button and type IP address (or domain name) of your MAC machine and press "OK".


5. try to connect to the added server

If you were able to connect to a device through Xamarin Mac Agen and there are no available devices in Select Deployment Target dialog, please, collect and send the logs idea.log and frontend.log (Help -> Show Log in ..  ) 

I've tried to reproduce the problem but without success. It would be great if you can help us to investigate the problem.


Kind regards,





I am having this issue on a Mac.  I cannot debug on an iOS device.  When I click the Debug button, Rider displays the iOS Select Deployment Target window.  This contains only Simulator devices.  I am using the iOS Device configuration with the Debug | Any CPU solution configuration.  When I edit the iOS Device configuration I set the Target to "Connected Device" and Name to my connected iPod touch.  I click Apply then OK.  I immediately re-open the configuration editor and the Target says "Open Select Deployment Target dialog".




With Debug | iPhoneSimulator and iOS Default, I now do get a populated list of Simulator devices. However, when I select one the simulator never comes up on my computer. The Simulator that I selected does come up on the connected Mac. With Visual Studio, the Simulator comes up on my own machine and I can interact with it. In VS, the Simulator does not come up on the connected Mac. It seems like there is an issue with where Rider decides to display the Simulator that it has just opened, perhaps.

The Mac that I am connecting to is not close to me physically, so this is not a workable solution. I have both of the logs that you requested, but I'm not sure how to send them. Let me know how I can give them to you and I will be more than happy to do so.


@Vthompson, I think our issues are slightly different - I don't have a physically connected device, I'm intending to use the simulator and having trouble with that. Just want to make sure that's clear to any JB staff or others reading this thread.



I am working on a Mac with Xcode and simulators installed. In my case select deployment target is empty. I've tried to select "Simulator" option in Target field Run/Debug Configurations, but then list in the name field is not populated with any simulators.

I am using 2018.2 Rider, macOS 10.14, Xcode 10.0, and simulator iOS 12.0




Has anyone got this to work on a Mac? Simulator list is empty but xcode shows them and even Visual Studio sees them !


Same problem as @Vthompson have. in "edit configuration..." I see my device, but in dialog "select deployment target" I don't see it, only emulators.

In VS for Mac it is ok, I can deploy and debug




I also am having issues deploying to iOS device on Mac in Rider only.  I can do simulator in Rider.


I am able to run on a simulator, but my connected device never shows up, so I have to resort to Visual Studio for iOS device deployments :/ (Android device shows up just fine)


I am having this issue too with the current version. This makes rider unusable for xamarin projects. Whether jetbrains looks into this and fix?



We are working to resolve the issue as quickly as possible and apologize for any inconvenience.  But unfortunately, it is hard to make an estimation right now due to some technical difficulties. I hope this functionality will be improved this year.

Here are issues for upvoting and asking questions:




Kind regards,



Please sign in to leave a comment.