Breakpoints not triggered

I have a C# .NET project that is being developed in Visual Studio 2015.
This project is a web project delivering REST web services and is created using Web Api 2.

I can open this solution in Rider without any problem.
I can actually also Run or Debug this program in Rider. It will start up without any problem. And the webservices funtion without any problem.

However, when I try to set a breakpoint they don't get triggered and the breakpoint is marked with : Not found associated module for breakpoint Xyz.cs:999



Since I am already using 

  • Android Studio for the Android client
  • IntelliJ for the GWT based web client
  • AppCode for the iOS client

it would be nice to be able to use Rider instead of VS for the development of the services.

9
54 comments

Hello, I started facing same problem after updating to  2019.1.1. My team mates faced it previously on several versions before 2019.1.1 (I just have not updated previously knowing about issue). We are using Rider on Mac to developer Xamarin applications. There are some info about my config:



Not sure is it connected somehow but in time of connecting debugger I see those events in event log:
Finally all breakpoints in shared .netstandard2.0 project looks like that(all breakpoints in Xamarin IOS project are working fine):
In previous versions of Rider I saw such notifications just after attaching debugger but closer to breakpoint(I think after appropriate class is touched) they become available, but right now they just not working. So it's actually blocker issue. I can't develop without debugger ;-D
If I can provide any additional info please ask. Thank you!

1

My solution was to delete the projects .idea folder, and then the breakpoints started working again.

0

Deleteing of .idea folder is not helped in my case. Actually finally I finished with removing whole project and setuping it from the scratch -  it didn't help also.

0

Experiencing same issue in 2019.1.1. Looks like it happens when you switch branches that have significant differences in the code. Cleaning Rider cache, solution, .idea folder, manually cleaning bin and other directories doesn't help.

1

Also having same issue with 2019.1.1

Additionaly I've noticed this does not seem to happen, if running Rider as Administrator on Windows. Now the breakpoints are hit.

 

 

0

We are using symlinks in Unity and this was the cause of breakpoint not being triggered. Problem solved for us.

1

Another thing that would probably trigger this is running 2 web apps from the same solution (i.e. web app dependent on service "api", both running at the same time). One app breakpoints work fine, another app doesn't trigger any.

1

@Yvdorofeev, please clarify your Rider version and operating system. Are you able to share a repro-solution?

Please,

- enable debugger tracing in "Help | Trace Scenario (LOGS)"

- reproduce the issue

- collect Rider logs (Help | Compress Logs and Show in)

- disable tracing

- share logs and a repro solution here

0

I am having the same issue with breakpoints showing this tooltip:

 

I am running JetBrain Rider 2019.1.2 on MacOS Mojave 10.14.5.

I tried generating a lot as Sofia Byzova mentioned above.  When I went to Help->Show Log in Finder things got really odd.  It took me to /Users/dale/Library/Logs/Rider2019.1/idea.log.  But the contents of the log is a copy of the projects .gitignore file. 

I have tried deleting the various obj, bin, cache, .proj* files and anything else I could find.  It still does not work.

1

I'm having the same problem as Dales.

0

Hi guys!

Please, create an issue on youtrack and attach the information

- enable debugger tracing in "Help | Trace Scenario (LOGS)"

- reproduce the issue

- collect Rider logs (Help | Compress Logs and Show in ...)

- disable tracing

- share logs and a repro solution (if possible)

- clarify your project type

 

Thanks!

0

I have just installed Rider 2019.2.2 on the same drive as my sln files (D drive). But I experience the exact same issue as Maggisig92.

The non-responsive breakpoint appears when trying to debug using Attach to Process. The process (dlls and pdbs) is run from the Program Files folder on C drive. I haven't built the solution. I am just trying to debug an existing dll. Please note that the solution's code and the dll/pdb are an exact match as the dll/pdb were created by a release build and the code is the same as that of the release that was used to generate the dll/pdb.

0

Hi @ebarten,

Please, create an issue on youtrack and attach the following information:

- enable debugger tracing in "Help | Trace Scenario (LOGS)"

- reproduce the issue

- collect Rider logs (Help | Compress Logs and Show in ...)

- disable tracing

- share logs and (a repro solution if possible)

- clarify your project type

 

Kind regard,

Sofia.

0

Cleaning and rebuilding solution worked for me and got the breakpoints to hit again. Try that.

1

Used Rider again since a long time today.

Problem is still not solved for me. 

0

Hello Frank. Sorry to hear the issue persists for you. Just as discussed before we would appreciate if you would collect the logs after reproduce with enabled Trace scenario and attach them with a new issue on our bug tracker. Thank you in advance!

0

I have the exact same issue and I cannot wait anymore. Everything seems to work well on VSCode so will just start using that as my IDE.

I have tried;

  • Rebooting my machine.
  • Reinstalling the dotnet core SDK.
  • Removing the .idea folder.
  • Deleting the project and re-cloning it from my git repository.
  • Currently, I'm on Rider 2020.1. Even tried downgrading to the previous version.
  • Deleted all "bin" and "obj" directories.
  • I've run clean on the project.

Nothing seems to work. Created ticket https://youtrack.jetbrains.com/issue/RIDER-43197

0

This is the most frustrating issue of Rider I've ever faced. On the same project I can easily debug with breakpoints in VS 2019 but not with Rider. Seriously RIDER!!!!!!

0

Hi Farshid,

 

To address this issue, we'll need some additional information.

1. Rider logs with an additional tracing scenario. To collect the logs, please follow these steps:

• Open a project that has this breakpoint issue

• Enable Debugger tracing via Help -> Diagnostic Tools -> Choose Trace Scenario

• Reproduce the issue

• Collect Rider logs (Help -> Collect logs)

• Disable tracing

2. Your project type. It would help if you could share a repro project with us.

 

Once you collect this data, please create a new issue on YouTrack. Note that project and logs can be shared privately (non-image attachments on the tracker are private by default)

 

Thank you in advance.

0

I have same issue, the brakpoint turns gray and says Didn't find associated module for a breakpoint 

0

Hi Vmachacek,

Please collect the necessary information and create a new issue on the tracker, as mentioned earlier in this thread. If you have any questions or encounter any issues collecting the data - let us know.

0

Hello everyone,

I just wanted to let everyone know that, if like me, you were looking for a way to provide smaller and more precise publish folders you may have entered the following lines in your .csproj PropertyGroup:

<DebugType>None</DebugType>
<DebugSymbols>false</DebugSymbols>

This leaves the PDBs out of your publish, but also makes it impossible to debug your application. It seems obvious now, but I had insufficient knowledge to know more than just copy pasting this into my .csproj. I hope it can help someone else.

1

In my case the issue been solved after cleaning up the rider cache (https://www.jetbrains.com/help/rider/Cleaning_System_Cache.html)

0

In my case, the breakpoint not being hit when debugging a project with IIS Express.

The solution was to run Rider as administrator 

More details here:
https://stackoverflow.com/questions/56681655/can-jetbrains-rider-work-properly-with-iisexpress

0

Please sign in to leave a comment.