Cannot resolve Symbols

Answered

 

It will compile well and work well on developer mode cmd.

I don't know why Jetrider's program cannot resolve this :/

16 comments
Comment actions Permalink

guess im using cmd to compile

0
Comment actions Permalink

Hi!

Thank you for contacting us.

Could you please check if the checkbox "File | Settings | Build, Execution, Deployment | Toolset and Build -> Use ReSharper Build" off. If no, turn it off and try to rebuild your project.

If the problem remains, please,

1. send a screenshot of your Toolset and Build settings.

2. check if cmd uses the same version of MSBuild.

3. try to rebuild your project (Build menu -> Rebuild). Does the problem remain?

 

Kind regards,

Sofia

0
Comment actions Permalink

Sadly I am facing a similar issue as that faced by @Tbae248.

 

I have a project which contiains the following structure:

src/classlibA - netcoreapp2.0

src/classlibB - net472

 

tests/classlibATests/ - includes classlibA as project reference (which internally includes another local library)

tests/classlibBTests/ - includes classlibB as project reference

tests/tests.sln - includes the *Tests.csproj's

 

Above is the screenshot of the toolset and build settings. 

 

What I see is that the IDE cannot resolve symbols for type comming from classlibA or classlibB. Now if I include all of these libraries that are referenced directly on the tests.sln. Then everything works, compiles and I can run my tests.

 

Additionally, I would like to highlight that the dotnetcli can build all these projects with no problems. Therefore clearly I am doing something wrong or structuring my project incorrectly.

 

Anyhow if you have some tips that would be greatly appreciated. 

 

Regards,

Ricardo

1
Comment actions Permalink

Any news on solving this issue?

I have the exact same issue.

How do you want to "2. check if cmd uses the same version of MSBuild." ? @Sofia Byzova

0
Comment actions Permalink

Hello!

Please, accept my apologies for the late reply!

@Ricardo Gaviria, @Rm, try to set up "Auto detected" in "File | Settings | Build, Execution, Deployment | Toolset and Build -> use MSBuild version" and then rebuild the solution. Does the problem persist?

If so, please collect Rider Logs (Help | Compress Logs and Show in ...), create a new ticket on youtrack, and attach your logs.

 

@Tbae248, I've created an issue in our tracker https://youtrack.jetbrains.com/issue/RIDER-26347 according to your problem. Please, collect all Rider logs and attach to the issue. Also, it would be helpful to get your csproj files and sln file.

 

Thank you!

0
Comment actions Permalink

@Tbae248, are you able to share a sample solution or csprojs and attach them to the issue https://youtrack.jetbrains.com/issue/RIDER-26347?

0
Comment actions Permalink

hi, 

I had same problem for long time, I used a project moved from Windows/VS2017 to Mac/Rider that refused to build. Unable to resolve import for a sibling project, so I was  forced to stay on Windows for this particular solution.

Doing the "set up "Auto detected" in "File | Settings | Build, Execution, Deployment | Toolset and Build -> use MSBuild version" and then rebuild the solution." solved my problem. Now thing works like a charm.

Why this problem? 

thanks 

 

giorgio 

0
Comment actions Permalink

This is still happening to me, why? Moved from VS to Rider and currently i cannot work at all. All the solutions suggested here does not work for me

0
Comment actions Permalink

Hi, Yuvgro, 

one of the thing I noticed long time ago, so it could be no more true, is that Rider had lot of problems managing namespaces different from the name of the folder including the source, something that VisualStudio was able to manage from day one. I changed lot of namespace names ...

0
Comment actions Permalink

I'm having a similar problem. My project builds and runs fine, but get a warning indicator on one particular line saying it cannot resolve the symbol. When I ctrl-click the parent of the property that cannot be resolved, Rider provides a decompiled version that clearly shows the property that it can't resolve.

Interestingly, after some investigation it seems that the library referenced in my case, `Microsoft.Extensions.PlatformAbstractions`, was removed from .net core after v1.1. Our project is using .net core 2.2. I wonder if it's only available due to being included in a dependency with old .net libs, and Rider doesn't know about that deeper dependency and is only looking at the .net core libs directly included in my project. As you can see in the second screenshot the version of this lib being decompiled appears to be from .net standard 1.3.

Here is the problem line:

Here is what Rider provides if I ctrl-click on `PlatformServices` in the problem line:

0
Comment actions Permalink

I tracked down the cached versions of `Microsoft.Extensions.PlatformAbstractions` and deleted them. Rebuilding the project then gave me a compile-time error about the package reference on the line in the first screenshot from my previous post, as expected since I couldn't find any dependencies that include that package (so it wouldn't have been retrieved by the build process).

However, after adding an explicit reference to the latest version of the package, we're back to square one. I still get the symbol not found error on `Default` and I can still inspect the `PlatformServices` class and see a public static `Default` property available.

0
Comment actions Permalink

I was able to replicate this bug with a fresh project simply by including the line from my screenshot above and the associated package reference. It builds but gives me the same "symbol not found" error over the red highlight text. There are no errors or warnings related to this during build. I added a related comment to the issue created earlier in this thread.

0
Comment actions Permalink

Hello Allyn!

Could you please share a sample solution via submitting a new support request ("Submit Request" button at the top of the current page)?

I've not managed to reproduce the problem.

Also, please clarify your Rider version ("Help | About" or "JetBrains Rider | About") and your operating system.

0
Comment actions Permalink

OS and Rider version below.

Windows 10 Pro (10.0.17134)

JetBrains Rider 2019.1.1
Build #RD-191.6733.985, built on May 1, 2019
Licensed to [redacted]
Subscription is active until October 12, 2019
JRE: 1.8.0_202-release-1483-b49 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

New issue submitted as requested: https://rider-support.jetbrains.com/hc/en-us/requests/2158954

0
Comment actions Permalink

Hi Allyn!

It seems that there is an invisible character between "e" and "f". Please, try to delete  "Default" and type it again. Does the problem persist?

0
Comment actions Permalink

Wow, that was it! I'm curious how you figured it out. Even when I copy and paste to a text editor that would normally allow me to see "invisible" characters I don't see it, but deleting the word `Default` and retyping it from scratch does get rid of the error.

0

Please sign in to leave a comment.