Rider ignores .meta files, though they're not in .gitignore

Completed

Hi everyone!

I'm having an issue with adding .meta files to git in Unity projects. When I try to commit via the Rider UI they're not listed under "untracked files" (they're also not marked as untracked in the solution explorer). In fact I can't add them at all.

They are not excluded in .gitignore, though. And when I use git in the cli they behave just fine. Meaning "git status" lists them as untracked and I can add them.

Anybody else having that issue?

4 comments
Comment actions Permalink

Can you go to Version Control -> Ignored Files in Rider's settings/preferences and see if you've got .meta files ignored?

0
Comment actions Permalink

No, theres also nothing in Version Control -> Ignored Files

I looked into the rest of the settings as well, but couldn't find anything related to the issue.

0
Comment actions Permalink

I also deleted all the project settings and made a fresh import into Rider, but that didn't help either. 

0
Comment actions Permalink

For anybody having this issue:

I found out that *.meta was indeed in Ignore files and folders under Editor > File Types which made Rider treat meta files as if they don't even belong to the project and also ignore them in VCS. Don't know how it got there or if that is the default.

Simply removing it solved it for me.

0

Please sign in to leave a comment.