Rider invisible after creating solution.


Hi, I took Rider for a spin, after installing the latest version ( 2018.2.3) off JetBrains Toolbox (1.7.3593 (Feb 14 2018)
OS kernel winnt 10.0.17134 on x86_64).  I can create a solution with .net core but after that, the Rider app goes invisible. I tried switching off a monitor since it the altab windows list showed rider as a rather elongated icon, but that did not help. If however, I alt tab to it and issue Alt+f4, it shows the confirmation dialog for exiting at the lower right corner. So in effect, I only see the entry and exit screens.




I found a work around -> Alt + Space  and x to maximize . 

Other things I tried : Reinstall, Windows + M to see if it was running the background, event viewer has nothing, Private bytes in Task manager kept growing


I'm on 2018.3.2 and can confirm that this is not fixed-- it happened to me on a fresh installation.


Same thing happening to me, but only for a single solution. The rest appear correctly. Cannot restore window at all. 


A "reset settings" option would help IMO.



UPDATE: Tried deleting .ndproj, .dotsettings and the .idea folder. Still nothing


This is happening to me right now.

Only the entry and exit screens show.

In my case, I'd been switching between second monitors in different desktop locations.

But even plugging in the original monitor I can't find the IDE.

The “choose project” entry screen works, but nothing appears when I open the project; no IDE.

When I “Close window” on task bar, the “exit?” confirmation appears.

But no IDE. Just entry and exit. I can't work. I will have no money.

Rider 2022.3.2


Workaround found by much faffing:
1) Start Rider

2) Open project (you can do this because the Entry screen works)

3) Now with invisible IDE, hover over Rider icon in the task bar (A white “mini window” pops up above it)

4) Right click on the white mini-window

5) Select “Maximize”

After much experimentation, this is the only way I could find my IDE ever again



I'm sorry you've faced this issue. Indeed, there is the only workaround is to call Alt+Space -> Maximize on the Rider icon on the taskbar.


Please sign in to leave a comment.