VS installation folder is not set

Completed

Hello guys,

 

I'm using Rider on Linux Ubuntu 18.04. Everything is OK except that I can't run tests via Rider and nearby there is a notification: Visual Studio installation folder is not set. There is the question: how can I set it?

0
6 comments

Hi!

At the moment Rider cannot run MSTest v2 unit tests in classic .NET projects without Visual Studio or VisualStudio TestAgent to be installed (only for Windows).

On Windows integration with VisualStudio can be activated in settings: File | Settings | Build, Execution, Deployment | Unit Testing | MSTest.

 

Kind regards,

Sofya

3

This is what you find in MSTest Settings and I quote:

IN order to run MSTest tests, Rider needs to use a console unit test runner that is distributed by Visual Studio and requires a Visual Studio  license. 

Go to File | Settings | Build, Execution, Deployment | Unit Testing | MSTest then

my problem got solved after adding the following path           C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE

It depends what version of VS you have, so Change the path accordingly. 

 

2

Hi Andrejus!

Thanks for the request.

Please provide the following information:

  1. Rider Version (Help | About)
  2. Do you have classic MSTest project or MSTest v2?
  3. Is it .NET Core or classic .NET project?

There was a problem with running MSTest Core unit tests from the editor, but it was fixed in 2018.2.2.

 

Kind regards,

Sofya

 

0

1. My version is 2018.2.3

2. MSTest.TestFramework is MSTestv2

3. It is classic .NET project (running on Mono)

0

I have the exact same issue as well but on Windows.

0

Please sign in to leave a comment.