Disable mouse popups when mousing over identifier under caret.

Answered

I do not want this popup (displaying the type of the identifier) to automatically show when mousing over an identifier containing the caret.  What feature is this and how can I disable it?

2 comments
Comment actions Permalink

I also cannot find any way to disable these and they are incredibly annoying. Sometimes they can hide several lines of code, and they don't always disappear instantly, or are buggy with when they show up. Please let us disable these JetBrains!

1
Comment actions Permalink

Hi there,

We have plans to improve the tooltips in the near future so that they are not that annoying. Please vote for RIDER-4796 and related issues on Rider tracker to increase their priority.

As a workaround, you can disable hover tooltips and use Quick Documentation action instead to study symbol documentation:

  1. To disable tooltips completely, go to Help | Find Action... | Registry and then check ide.disable.editor.tooltips=true. Alternatively, change editor tooltip delay: set ide.tooltip.initialReshowDelay to like 1500 or whatever you feel comfortable with
  2. Go to "Preferences | Keymap" and find Quick Documentation action
  3. Right-click on the action -> Add Keyboard/Mouse Shortcut and add a handy shortcut to it
3

Please sign in to leave a comment.