Rider can't find SignalR

Completed
Microsoft.AspNetCore.SignalR

Is part of .Net Core 2.1.

I have my Target framework set to "netappcore2.1", but Rider can't find SignalR.  Everything builds and works fine in Visual Studio, so the package is there.

How can I get Rider to find SignalR?

2 comments
Comment actions Permalink

Facing the exact same issue on a project. @Darrengriffith , did you ever get anywhere with this?

0
Comment actions Permalink

I got this suggestion from JetBrains: Please try to switch MSBuild to the one from .NET Core in "Preferences | Build, Execution, Deployment | Toolset and Build".

That would fix the issue for a while, then it would pop up again.

It seems to be more stable after I've upgraded to .Net 2.1.403 and Rider 2018.3.

0

Please sign in to leave a comment.