Debugger issue in 2018.1 for netframework 4.6.1: Cannot detect dbgshim

After updating from Rider 2017.3 to 2018.1 (Windows 10) I cannot debug projects targeting .Net Framework 4.6.1. If I go back to 2017.3 everything works fine.

I can run the project without debugging in 2018.1 but I just cannot debug.

This issue looks like it is related to the issue linked below however that issue is regarding .Net Core 2.1 and appears to have been fixed.

https://rider-support.jetbrains.com/hc/en-us/community/posts/360000126224-Cannot-debug-Cannot-detect-dbgshim-path-for-execute-pat-?input_string=Debugger%20issue%20in%202018.1%20for%20netframework%204.6.1%3A%20Cannot%20detect%20dbgshim

0
4 comments

I also just had this problem.  I converted a project from netcoreapp2.0 to net461 and now cannot debug.  Tried a restart but no joy.

0

Tom, James,

Does this reproduce on the latest version (2018.1.1)? If so, could you create an issue in Rider tracker and attach a repro solution to it? Please post a link to the issue here.

0

I am using 2018.1.1 yes.  Will try to create a repro at some point - without retrying and off the top of my head, I just created a new solution then new netcoreapp2.0 console project.  I added a few nuget refs and then decided to go back to net461.  Once I did that using the framework dialog box (not directly editing the csproj), it successfully changed the nuget refs but the debugger stopped working with this error.  A rider restart didn't help.

0

Since none of the solutions here worked for me, I found a solution that worked for me:

 

When I discovered all the installed .NET Core SDKs on my Windows Machine (via Add / Remove Progams), I found out that .NET Core 3.1 (which is the version that did not work with the debugger anymore) was installed multiple times (probably by visual studio etc.)

So what I did to get debugging working again:

1. Uninstalled Visual Studio

2. Uninstalled all .NET Core 3.X.X Versions of Runtime and/or SDK

3. Reinstalled a fresh .NET Core 3.X.X 

I also reinstalled Rider several times before, but I guess that is not really neccessary.

 

I hope this helps people facing the same problem!

0

Please sign in to leave a comment.