Typeover parentheses after autocompleted method names

Answered

I'm trying to migrate from Visual Studio, and the one thing holding me back is Rider's insistence on automatically filling in parentheses after I autocomplete the name of a method. For as incredibly configurable as Rider's code editor is everywhere else, it's surprising that there's no option to disable this behavior. I'm sure I could adapt and learn to stop typing my own parentheses, but then I'll have the opposite problem whenever I use an IDE that doesn't support auto-parentheses. It would be great if Rider supported typeover parentheses, where parentheses are auto-generated, but are overwritten if the first characters you type are a space (if your preference is to insert a space after a method name) or an opening parenthesis. Barring that, a simple option to disable automatic generation of parentheses on autocomplete would suffice.

7 comments
Comment actions Permalink

This is actually the thing that's keeping me from switching over as well. ReSharper in Visual Studio has the option to toggle autogenerated parentheses on and off, but it's missing in Rider. I keep trying to code in Rider and this trips me up every time I write a method call, to the point that it feels like I'm stumbling and editing so much I just switch back to Visual Studio.

0
Comment actions Permalink

I just spent a day trying to switch over from MonoDevelop to while working in Unity. After spending about 3 hours trying to disable this I have given up on Rider and switched back to Mono, which is awful. Until this is fix I will not use Rider and will never recommend it to anyone.

0
Comment actions Permalink

I really want to start using Rider but I just can't live without this feature. It makes programming feel so fluent.

0
Comment actions Permalink

Hi there,

The newly released Rider 2018.2 has a new setting named "Automatically insert parentheses after completion", which has three states: "None", "Opening only", "Both opening and closing".

Hope it helps. Thank you for your feedback!

0
Comment actions Permalink

For some reason I do not see that option and I am on 2018.2.

0
Comment actions Permalink

I just tried out the setting but unfortunately it was not what I was looking for. But thank you for the response.

0
Comment actions Permalink

@Versov1 What Rider build are you using (Help -> About)? I have just tested it on 2018.2 RTM (Build #RD-182.4231.193).

0

Please sign in to leave a comment.