How do I tell Rider what version of the framework to target for its inspections?

Answered

My current solution and projects are using .NET 4.5, but Rider keeps suggesting code improvements for later versions of the framework.

For example, "Use string interpolation expression" instead of string.Format().

Is there a way to change the target version of the .NET Framework so that Rider doesn't suggest things that will fail to compile when I switch back to Visual Studio?

Ideally this would be per-project (not per-solution) because I have another solution which contains both .NET 3.5 and .NET 4.5 solutions.

1 comment
Comment actions Permalink

 

Would tag LangVersion work for you? You can can edit it via Project Properties.

0

Please sign in to leave a comment.